summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Boibessot2010-02-12 23:47:37 +0100
committerPeter Korsgaard2010-02-17 11:26:09 +0100
commit0c6ef230f32eb37a23c47afd862e393dacf8f308 (patch)
treecbe2009370097f3c369cc6dd47c5c91d0245d783
parentCHANGES: add alsa-lib, rsync, tcl and xproto_trapproto (diff)
downloadbuildroot-0c6ef230f32eb37a23c47afd862e393dacf8f308.tar.gz
buildroot-0c6ef230f32eb37a23c47afd862e393dacf8f308.tar.xz
buildroot-0c6ef230f32eb37a23c47afd862e393dacf8f308.zip
gstreamer-good: add speex dependancy
Otherwise, even if speex is selected, as gstreamer is compiled first, speex plugin is not activated/built. Signed-off-by: Julien Boibessot <julien.boibessot@armadeus.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES4
-rw-r--r--package/multimedia/gst-plugins-good/Config.in4
-rw-r--r--package/multimedia/gst-plugins-good/gst-plugins-good.mk7
3 files changed, 13 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index 130ebf057..37bc22c1b 100644
--- a/CHANGES
+++ b/CHANGES
@@ -2,8 +2,8 @@
Fixes all over the tree and new features.
- Updated/fixed packages: alsa-lib, argus, at, libpcap, rsync, tcl,
- xproto_trapproto
+ Updated/fixed packages: alsa-lib, argus, at, gst-plugins-good,
+ libpcap, rsync, tcl, xproto_trapproto
2010.02-rc1, Released February 9th, 2010:
diff --git a/package/multimedia/gst-plugins-good/Config.in b/package/multimedia/gst-plugins-good/Config.in
index fdb6646ae..a326dc933 100644
--- a/package/multimedia/gst-plugins-good/Config.in
+++ b/package/multimedia/gst-plugins-good/Config.in
@@ -172,4 +172,8 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SOUPHTTPSRC
bool "souphttpsrc (http client)"
select BR2_PACKAGE_LIBSOUP
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SPEEX
+ bool "speex"
+ select BR2_PACKAGE_SPEEX
+
endif
diff --git a/package/multimedia/gst-plugins-good/gst-plugins-good.mk b/package/multimedia/gst-plugins-good/gst-plugins-good.mk
index 7b6f02bea..19a53e6e2 100644
--- a/package/multimedia/gst-plugins-good/gst-plugins-good.mk
+++ b/package/multimedia/gst-plugins-good/gst-plugins-good.mk
@@ -318,4 +318,11 @@ else
GST_PLUGINS_GOOD_CONF_OPT += --disable-soup
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SPEEX),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-speex
+GST_PLUGINS_GOOD_DEPENDENCIES += speex
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-speex
+endif
+
$(eval $(call AUTOTARGETS,package/multimedia,gst-plugins-good))