summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni2010-04-28 23:40:52 +0200
committerPeter Korsgaard2010-05-03 00:00:05 +0200
commit4c5bf461cd8cec58ff56b72d09a7fc45b0599636 (patch)
tree67bd637fa4ed1660bd18d449ce71eefb4890b5cb
parentuclibc: make sure the default configuration doesn't ask questions (diff)
downloadbuildroot-4c5bf461cd8cec58ff56b72d09a7fc45b0599636.tar.gz
buildroot-4c5bf461cd8cec58ff56b72d09a7fc45b0599636.tar.xz
buildroot-4c5bf461cd8cec58ff56b72d09a7fc45b0599636.zip
Commonalize the definition of TOOLCHAIN_DIR
The definition of TOOLCHAIN_DIR is the same regardless of whether external or internal toolchains are used. Moreover, move its definition together with all the other *_DIR definitions. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--Makefile1
-rw-r--r--package/Makefile.in2
2 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 54dd4f185..271db9c59 100644
--- a/Makefile
+++ b/Makefile
@@ -267,6 +267,7 @@ STAMP_DIR:=$(BASE_DIR)/stamps
BINARIES_DIR:=$(BASE_DIR)/images
TARGET_DIR:=$(BASE_DIR)/target
+TOOLCHAIN_DIR=$(BASE_DIR)/toolchain
BR2_DEPENDS_DIR=$(BUILD_DIR)/buildroot-config
diff --git a/package/Makefile.in b/package/Makefile.in
index 3dfc712da..396187d3b 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -105,7 +105,6 @@ ROOTFS_SUFFIX:=-$(BR2_ROOTFS_SUFFIX)
endif
ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
-TOOLCHAIN_DIR=$(BASE_DIR)/toolchain
# Quotes are needed for spaces et al in path components.
TARGET_PATH="$(TOOLCHAIN_DIR)/bin:$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(HOST_DIR)/usr/sbin/:$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/bin:$(PATH)"
@@ -116,7 +115,6 @@ KERNEL_CROSS=$(TARGET_CROSS)
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL),y)
TOOLCHAIN_EXTERNAL_PREFIX:=$(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PREFIX))
TOOLCHAIN_EXTERNAL_PATH:=$(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PATH))
-TOOLCHAIN_DIR=$(BASE_DIR)/toolchain
TARGET_PATH="$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(HOST_DIR)/usr/sbin/:$(TOOLCHAIN_DIR)/bin:$(TOOLCHAIN_EXTERNAL_PATH)/bin:$(PATH)"
REAL_GNU_TARGET_NAME=$(TOOLCHAIN_EXTERNAL_PREFIX)
GNU_TARGET_NAME=$(TOOLCHAIN_EXTERNAL_PREFIX)