summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Dawson2012-06-04 22:32:15 +0200
committerPeter Korsgaard2012-06-12 23:32:18 +0200
commit5c959c117d9079432e6e03c249a6534cca4eb6eb (patch)
tree15d549aed70c183d4847a664e2a2522fc8cea697
parentlibfreefare: new package (diff)
downloadbuildroot-5c959c117d9079432e6e03c249a6534cca4eb6eb.tar.gz
buildroot-5c959c117d9079432e6e03c249a6534cca4eb6eb.tar.xz
buildroot-5c959c117d9079432e6e03c249a6534cca4eb6eb.zip
nanocom: new package
Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/Config.in1
-rw-r--r--package/nanocom/Config.in11
-rw-r--r--package/nanocom/nanocom.mk27
3 files changed, 39 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 13310b20c..b3a2f8011 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -209,6 +209,7 @@ source "package/mdadm/Config.in"
source "package/memtester/Config.in"
source "package/minicom/Config.in"
source "package/mtd/Config.in"
+source "package/nanocom/Config.in"
source "package/ntfs-3g/Config.in"
source "package/ofono/Config.in"
source "package/open2300/Config.in"
diff --git a/package/nanocom/Config.in b/package/nanocom/Config.in
new file mode 100644
index 000000000..51d628aec
--- /dev/null
+++ b/package/nanocom/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_NANOCOM
+ bool "nanocom"
+ help
+ Nanocom is based upon microcom (http://microcom.port5.com/) but
+ removes the scripting and logging features while introducing support
+ for setting local/remote echo, parity and stop bits. It also follows
+ a more standard command line style using the getopt function.
+ Internally much of the code has been rewritten and reformatted, the
+ menu system in particular is almost entirely different.
+
+ http://nanocom.sourceforge.net/
diff --git a/package/nanocom/nanocom.mk b/package/nanocom/nanocom.mk
new file mode 100644
index 000000000..4fb7aee79
--- /dev/null
+++ b/package/nanocom/nanocom.mk
@@ -0,0 +1,27 @@
+#############################################################
+#
+# nanocom
+#
+#############################################################
+NANOCOM_VERSION = 2.6.1
+NANOCOM_SOURCE = nanocom.tar.gz
+NANOCOM_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/project/nanocom/nanocom/v1.0
+
+# N.B. Don't strip any path components during extraction.
+define NANOCOM_EXTRACT_CMDS
+ gzip -d -c $(DL_DIR)/$(NANOCOM_SOURCE) | tar --strip-components=0 -C $(NANOCOM_DIR) -xf -
+endef
+
+define NANOCOM_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define NANOCOM_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 -D $(@D)/nanocom $(TARGET_DIR)/usr/bin/nanocom
+endef
+
+define NANOCOM_UNINSTALL_TARGET_CMDS
+ $(RM) $(TARGET_DIR)/usr/bin/nanocom
+endef
+
+$(eval $(call GENTARGETS))