summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Schmelzer2012-06-25 20:10:38 +0200
committerSebastian Schmelzer2012-06-25 20:10:38 +0200
commit5e13d7dd1fbdb6fee24614f12312e7cbfd79cdf6 (patch)
tree446f3645c5aed441c6adca8b81633127115fffe0
parentactivate zram support for kernel (diff)
downloadbuildroot-5e13d7dd1fbdb6fee24614f12312e7cbfd79cdf6.tar.gz
buildroot-5e13d7dd1fbdb6fee24614f12312e7cbfd79cdf6.tar.xz
buildroot-5e13d7dd1fbdb6fee24614f12312e7cbfd79cdf6.zip
add openslx systemd variant
-rw-r--r--package/systemd/systemd-fix-getty-unit.patch34
-rw-r--r--package/systemd/systemd-fix-page-size.patch43
-rw-r--r--package/systemd/systemd-openslx.patch555
-rw-r--r--package/systemd/systemd-uclibc-fix.patch59
-rw-r--r--package/systemd/systemd.mk2
5 files changed, 556 insertions, 137 deletions
diff --git a/package/systemd/systemd-fix-getty-unit.patch b/package/systemd/systemd-fix-getty-unit.patch
deleted file mode 100644
index 6df54b132..000000000
--- a/package/systemd/systemd-fix-getty-unit.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Prefer getty to agetty in console setup systemd units
-
-Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
----
- units/getty@.service.m4 | 2 +-
- units/serial-getty@.service.m4 | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-Index: systemd-37/units/getty@.service.m4
-===================================================================
---- systemd-37.orig/units/getty@.service.m4
-+++ systemd-37/units/getty@.service.m4
-@@ -32,7 +32,7 @@
-
- [Service]
- Environment=TERM=linux
--ExecStart=-/sbin/agetty %I 38400
-+ExecStart=-/sbin/getty -L %I 115200 vt100
- Restart=always
- RestartSec=0
- UtmpIdentifier=%I
-Index: systemd-37/units/serial-getty@.service.m4
-===================================================================
---- systemd-37.orig/units/serial-getty@.service.m4
-+++ systemd-37/units/serial-getty@.service.m4
-@@ -32,7 +32,7 @@
-
- [Service]
- Environment=TERM=vt100
--ExecStart=-/sbin/agetty -s %I 115200,38400,9600
-+ExecStart=-/sbin/getty -L %I 115200 vt100
- Restart=always
- RestartSec=0
- UtmpIdentifier=%I
diff --git a/package/systemd/systemd-fix-page-size.patch b/package/systemd/systemd-fix-page-size.patch
deleted file mode 100644
index 241ceb8c0..000000000
--- a/package/systemd/systemd-fix-page-size.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-commit 7264278fbbdc1dc6c30fedc902d1337594aa6ff6
-Author: Lennart Poettering <lennart@poettering.net>
-Date: Wed Mar 21 23:47:44 2012 +0100
-
- journal: PAGE_SIZE is not known on ppc and other archs
-
- Let's use NAME_MAX, as suggested by Dan Walsh
-
-diff --git a/src/journal/journald.c b/src/journal/journald.c
-index d27cb60..87390bd 100644
---- a/src/journal/journald.c
-+++ b/src/journal/journald.c
-@@ -29,7 +29,6 @@
- #include <sys/ioctl.h>
- #include <linux/sockios.h>
- #include <sys/statvfs.h>
--#include <sys/user.h>
-
- #include <systemd/sd-journal.h>
- #include <systemd/sd-login.h>
-@@ -2149,10 +2148,20 @@ static int process_event(Server *s, struct epoll_event *ev) {
- size_t label_len = 0;
- union {
- struct cmsghdr cmsghdr;
-+
-+ /* We use NAME_MAX space for the
-+ * SELinux label here. The kernel
-+ * currently enforces no limit, but
-+ * according to suggestions from the
-+ * SELinux people this will change and
-+ * it will probably be identical to
-+ * NAME_MAX. For now we use that, but
-+ * this should be updated one day when
-+ * the final limit is known.*/
- uint8_t buf[CMSG_SPACE(sizeof(struct ucred)) +
- CMSG_SPACE(sizeof(struct timeval)) +
-- CMSG_SPACE(sizeof(int)) +
-- CMSG_SPACE(PAGE_SIZE)]; /* selinux label */
-+ CMSG_SPACE(sizeof(int)) + /* fd */
-+ CMSG_SPACE(NAME_MAX)]; /* selinux label */
- } control;
- ssize_t n;
- int v;
diff --git a/package/systemd/systemd-openslx.patch b/package/systemd/systemd-openslx.patch
new file mode 100644
index 000000000..890cfda37
--- /dev/null
+++ b/package/systemd/systemd-openslx.patch
@@ -0,0 +1,555 @@
+diff -wur systemd-185/src/core/main.c systemd-185.openslx/src/core/main.c
+--- systemd-185/src/core/main.c 2012-05-31 11:48:49.574023370 +0200
++++ systemd-185.openslx/src/core/main.c 2012-06-25 18:42:04.918373999 +0200
+@@ -177,7 +177,7 @@
+ else if ((r = make_stdio(fd)) < 0)
+ log_error("Failed to duplicate terminal fd: %s", strerror(-r));
+
+- execl("/bin/sh", "/bin/sh", NULL);
++ execl("/openslx/bin/sh", "/openslx/bin/sh", NULL);
+
+ log_error("execl() failed: %s", strerror(errno));
+ _exit(1);
+@@ -1774,10 +1774,10 @@
+ if (errno == ENOENT) {
+ log_warning("No /sbin/init, trying fallback");
+
+- args[0] = "/bin/sh";
++ args[0] = "/openslx/bin/sh";
+ args[1] = NULL;
+ execv(args[0], (char* const*) args);
+- log_error("Failed to execute /bin/sh, giving up: %m");
++ log_error("Failed to execute /openslx/bin/sh, giving up: %m");
+ } else
+ log_warning("Failed to execute /sbin/init, giving up: %m");
+ }
+diff -wur systemd-185/src/core/mount.c systemd-185.openslx/src/core/mount.c
+--- systemd-185/src/core/mount.c 2012-05-31 12:39:40.502669670 +0200
++++ systemd-185.openslx/src/core/mount.c 2012-06-25 18:39:46.518374826 +0200
+@@ -79,7 +79,7 @@
+ m->exec_context.std_error = u->manager->default_std_error;
+ }
+
+- /* We need to make sure that /bin/mount is always called in
++ /* We need to make sure that /openslx/bin/mount is always called in
+ * the same process group as us, so that the autofs kernel
+ * side doesn't send us another mount request while we are
+ * already trying to comply its last one. */
+@@ -887,7 +887,7 @@
+
+ if ((r = exec_command_set(
+ m->control_command,
+- "/bin/umount",
++ "/openslx/bin/umount",
+ m->where,
+ NULL)) < 0)
+ goto fail;
+@@ -925,7 +925,7 @@
+ if (m->from_fragment)
+ r = exec_command_set(
+ m->control_command,
+- "/bin/mount",
++ "/openslx/bin/mount",
+ m->parameters_fragment.what,
+ m->where,
+ "-t", m->parameters_fragment.fstype ? m->parameters_fragment.fstype : "auto",
+@@ -981,7 +981,7 @@
+
+ r = exec_command_set(
+ m->control_command,
+- "/bin/mount",
++ "/openslx/bin/mount",
+ m->parameters_fragment.what,
+ m->where,
+ "-t", m->parameters_fragment.fstype ? m->parameters_fragment.fstype : "auto",
+diff -wur systemd-185/src/core/shutdown.c systemd-185.openslx/src/core/shutdown.c
+--- systemd-185/src/core/shutdown.c 2012-05-31 12:39:40.502669670 +0200
++++ systemd-185.openslx/src/core/shutdown.c 2012-06-25 20:06:53.928343597 +0200
+@@ -477,7 +477,7 @@
+ log_warning("kexec failed. Falling back to normal reboot.");
+ } else {
+ /* Child */
+- const char *args[3] = { "/sbin/kexec", "-e", NULL };
++ const char *args[3] = { "/openslx/sbin/kexec", "-e", NULL };
+ execv(args[0], (char * const *) args);
+ return EXIT_FAILURE;
+ }
+diff -wur systemd-185/src/core/swap.c systemd-185.openslx/src/core/swap.c
+--- systemd-185/src/core/swap.c 2012-05-25 03:14:20.223928784 +0200
++++ systemd-185.openslx/src/core/swap.c 2012-06-25 20:07:27.415010065 +0200
+@@ -712,7 +712,7 @@
+
+ r = exec_command_set(
+ s->control_command,
+- "/sbin/swapon",
++ "/openslx/sbin/swapon",
+ "-p",
+ p,
+ s->what,
+@@ -720,7 +720,7 @@
+ } else
+ r = exec_command_set(
+ s->control_command,
+- "/sbin/swapon",
++ "/openslx/sbin/swapon",
+ s->what,
+ NULL);
+
+@@ -751,7 +751,7 @@
+
+ if ((r = exec_command_set(
+ s->control_command,
+- "/sbin/swapoff",
++ "/openslx/sbin/swapoff",
+ s->what,
+ NULL)) < 0)
+ goto fail;
+diff -wur systemd-185/src/core/switch-root.c systemd-185.openslx/src/core/switch-root.c
+--- systemd-185/src/core/switch-root.c 2012-05-22 16:54:33.751007201 +0200
++++ systemd-185.openslx/src/core/switch-root.c 2012-06-25 19:45:48.695017824 +0200
+@@ -29,6 +29,7 @@
+
+ #include "util.h"
+ #include "path-util.h"
++#include "missing.h"
+ #include "switch-root.h"
+
+ int switch_root(const char *new_root) {
+diff -wur systemd-185/src/hostname/org.freedesktop.hostname1.service systemd-185.openslx/src/hostname/org.freedesktop.hostname1.service
+--- systemd-185/src/hostname/org.freedesktop.hostname1.service 2012-04-12 01:04:30.618222912 +0200
++++ systemd-185.openslx/src/hostname/org.freedesktop.hostname1.service 2012-06-25 18:44:57.398372969 +0200
+@@ -7,6 +7,6 @@
+
+ [D-BUS Service]
+ Name=org.freedesktop.hostname1
+-Exec=/bin/false
++Exec=/openslx/bin/false
+ User=root
+ SystemdService=dbus-org.freedesktop.hostname1.service
+diff -wur systemd-185/src/journal/cat.c systemd-185.openslx/src/journal/cat.c
+--- systemd-185/src/journal/cat.c 2012-04-12 01:04:30.618222912 +0200
++++ systemd-185.openslx/src/journal/cat.c 2012-06-25 18:38:27.781708630 +0200
+@@ -159,7 +159,7 @@
+ fd = -1;
+
+ if (argc <= optind)
+- execl("/bin/cat", "/bin/cat", NULL);
++ execl("/openslx/bin/cat", "/openslx/bin/cat", NULL);
+ else
+ execvp(argv[optind], argv + optind);
+
+diff -wur systemd-185/src/journal/journal-file.c systemd-185.openslx/src/journal/journal-file.c
+--- systemd-185/src/journal/journal-file.c 2012-05-22 02:04:04.891877266 +0200
++++ systemd-185.openslx/src/journal/journal-file.c 2012-06-25 19:38:51.481686983 +0200
+@@ -230,12 +230,14 @@
+ }
+ }
+
++#ifndef __UCLIBC__
+ /* Note that the glibc fallocate() fallback is very
+ inefficient, hence we try to minimize the allocation area
+ as we can. */
+ r = posix_fallocate(f->fd, old_size, new_size - old_size);
+ if (r != 0)
+ return -r;
++#endif
+
+ if (fstat(f->fd, &f->last_stat) < 0)
+ return -errno;
+diff -wur systemd-185/src/locale/org.freedesktop.locale1.service systemd-185.openslx/src/locale/org.freedesktop.locale1.service
+--- systemd-185/src/locale/org.freedesktop.locale1.service 2012-04-12 01:04:30.621222912 +0200
++++ systemd-185.openslx/src/locale/org.freedesktop.locale1.service 2012-06-25 18:38:49.188375171 +0200
+@@ -7,6 +7,6 @@
+
+ [D-BUS Service]
+ Name=org.freedesktop.locale1
+-Exec=/bin/false
++Exec=/openslx/bin/false
+ User=root
+ SystemdService=dbus-org.freedesktop.locale1.service
+diff -wur systemd-185/src/login/org.freedesktop.login1.service systemd-185.openslx/src/login/org.freedesktop.login1.service
+--- systemd-185/src/login/org.freedesktop.login1.service 2012-04-12 01:04:30.623222912 +0200
++++ systemd-185.openslx/src/login/org.freedesktop.login1.service 2012-06-25 18:45:24.981706138 +0200
+@@ -7,6 +7,6 @@
+
+ [D-BUS Service]
+ Name=org.freedesktop.login1
+-Exec=/bin/false
++Exec=/openslx/bin/false
+ User=root
+ SystemdService=dbus-org.freedesktop.login1.service
+diff -wur systemd-185/src/nspawn/nspawn.c systemd-185.openslx/src/nspawn/nspawn.c
+--- systemd-185/src/nspawn/nspawn.c 2012-05-31 20:22:14.262509254 +0200
++++ systemd-185.openslx/src/nspawn/nspawn.c 2012-06-25 18:44:18.438373202 +0200
+@@ -1099,7 +1099,7 @@
+ execvpe(argv[optind], argv + optind, (char**) envp);
+ else {
+ chdir(home ? home : "/root");
+- execle("/bin/bash", "-bash", NULL, (char**) envp);
++ execle("/openslx/bin/bash", "-bash", NULL, (char**) envp);
+ }
+
+ log_error("execv() failed: %m");
+diff -wur systemd-185/src/remount-fs/remount-fs.c systemd-185.openslx/src/remount-fs/remount-fs.c
+--- systemd-185/src/remount-fs/remount-fs.c 2012-05-08 01:57:17.740095802 +0200
++++ systemd-185.openslx/src/remount-fs/remount-fs.c 2012-06-25 18:37:34.325042284 +0200
+@@ -97,15 +97,15 @@
+ const char *arguments[5];
+ /* Child */
+
+- arguments[0] = "/bin/mount";
++ arguments[0] = "/openslx/bin/mount";
+ arguments[1] = me->mnt_dir;
+ arguments[2] = "-o";
+ arguments[3] = "remount";
+ arguments[4] = NULL;
+
+- execv("/bin/mount", (char **) arguments);
++ execv("/openslx/bin/mount", (char **) arguments);
+
+- log_error("Failed to execute /bin/mount: %m");
++ log_error("Failed to execute /openslx/bin/mount: %m");
+ _exit(EXIT_FAILURE);
+ }
+
+@@ -146,9 +146,9 @@
+ if (s) {
+ if (!is_clean_exit(si.si_code, si.si_status)) {
+ if (si.si_code == CLD_EXITED)
+- log_error("/bin/mount for %s exited with exit status %i.", s, si.si_status);
++ log_error("/openslx/bin/mount for %s exited with exit status %i.", s, si.si_status);
+ else
+- log_error("/bin/mount for %s terminated by signal %s.", s, signal_to_string(si.si_status));
++ log_error("/openslx/bin/mount for %s terminated by signal %s.", s, signal_to_string(si.si_status));
+
+ ret = EXIT_FAILURE;
+ }
+diff -wur systemd-185/src/shared/macro.h systemd-185.openslx/src/shared/macro.h
+--- systemd-185/src/shared/macro.h 2012-05-08 01:57:17.656095804 +0200
++++ systemd-185.openslx/src/shared/macro.h 2012-06-25 19:39:41.575020016 +0200
+@@ -28,6 +28,23 @@
+ #include <sys/uio.h>
+ #include <inttypes.h>
+
++#ifdef __UCLIBC__
++/* uclibc does not implement mkostemp GNU extension */
++#define mkostemp(x,y) mkstemp(x)
++/* uclibc does not implement execvpe GNU extension */
++#ifndef _GNU_SOURCE
++#define _GNU_SOURCE
++#endif
++#include <unistd.h>
++static inline int execvpe(const char *file, char *const argv[],
++ char *const envp[])
++{
++ environ = (char **)envp;
++ return execvp(file, argv);
++}
++#endif
++
++
+ #define _printf_attr_(a,b) __attribute__ ((format (printf, a, b)))
+ #define _sentinel_ __attribute__ ((sentinel))
+ #define _noreturn_ __attribute__((noreturn))
+diff -wur systemd-185/src/udev/keymap/check-keymaps.sh systemd-185.openslx/src/udev/keymap/check-keymaps.sh
+--- systemd-185/src/udev/keymap/check-keymaps.sh 2012-04-13 15:38:11.006520858 +0200
++++ systemd-185.openslx/src/udev/keymap/check-keymaps.sh 2012-06-25 20:05:19.998344159 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/openslx/bin/bash
+
+ # check that all key names in keymaps/* are known in <linux/input.h>
+ # and that all key maps listed in the rules are valid and present in
+diff -wur systemd-185/src/udev/keymap/findkeyboards systemd-185.openslx/src/udev/keymap/findkeyboards
+--- systemd-185/src/udev/keymap/findkeyboards 2012-04-04 00:44:27.744055165 +0200
++++ systemd-185.openslx/src/udev/keymap/findkeyboards 2012-06-25 20:06:13.815010504 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/sh -e
++#!/openslx/bin/sh -e
+ # Find "real" keyboard devices and print their device path.
+ # Author: Martin Pitt <martin.pitt@ubuntu.com>
+ #
+diff -wur systemd-185/src/udev/keymap/keyboard-force-release.sh systemd-185.openslx/src/udev/keymap/keyboard-force-release.sh
+--- systemd-185/src/udev/keymap/keyboard-force-release.sh 2012-06-04 20:16:53.647460647 +0200
++++ systemd-185.openslx/src/udev/keymap/keyboard-force-release.sh 2012-06-25 20:05:30.345010763 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/sh -e
++#!/openslx/bin/sh -e
+ # read list of scancodes, convert hex to decimal and
+ # append to the atkbd force_release sysfs attribute
+ # $1 sysfs devpath for serioX
+diff -wur systemd-185/src/udev/keymap/keyboard-force-release.sh.in systemd-185.openslx/src/udev/keymap/keyboard-force-release.sh.in
+--- systemd-185/src/udev/keymap/keyboard-force-release.sh.in 2012-06-04 12:43:31.119305508 +0200
++++ systemd-185.openslx/src/udev/keymap/keyboard-force-release.sh.in 2012-06-25 20:05:42.231677359 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/sh -e
++#!/openslx/bin/sh -e
+ # read list of scancodes, convert hex to decimal and
+ # append to the atkbd force_release sysfs attribute
+ # $1 sysfs devpath for serioX
+diff -wur systemd-185/units/console-getty.service.m4.in systemd-185.openslx/units/console-getty.service.m4.in
+--- systemd-185/units/console-getty.service.m4.in 2012-05-31 20:23:02.825548823 +0200
++++ systemd-185.openslx/units/console-getty.service.m4.in 2012-06-25 20:02:25.391678536 +0200
+@@ -30,7 +30,7 @@
+ Before=getty.target
+
+ [Service]
+-ExecStart=-/sbin/agetty --noclear -s console 115200,38400,9600
++ExecStart=-/openslx/sbin/agetty --noclear -s console 115200,38400,9600
+ Type=idle
+ Restart=always
+ RestartSec=0
+diff -wur systemd-185/units/console-shell.service.m4.in systemd-185.openslx/units/console-shell.service.m4.in
+--- systemd-185/units/console-shell.service.m4.in 2012-04-24 14:49:10.162332686 +0200
++++ systemd-185.openslx/units/console-shell.service.m4.in 2012-06-25 20:02:25.391678536 +0200
+@@ -31,7 +31,7 @@
+ [Service]
+ Environment=HOME=/root
+ WorkingDirectory=/root
+-ExecStart=-/sbin/sulogin
++ExecStart=-/openslx/sbin/sulogin
+ ExecStopPost=-@SYSTEMCTL@ poweroff
+ Type=idle
+ StandardInput=tty-force
+diff -wur systemd-185/units/emergency.service systemd-185.openslx/units/emergency.service
+--- systemd-185/units/emergency.service 2012-06-04 20:17:02.143457560 +0200
++++ systemd-185.openslx/units/emergency.service 2012-06-25 20:02:25.388345203 +0200
+@@ -14,10 +14,10 @@
+ [Service]
+ Environment=HOME=/root
+ WorkingDirectory=/root
+-ExecStartPre=-/bin/plymouth quit
+-ExecStartPre=-/bin/echo 'Welcome to emergency mode. Use "systemctl default" or ^D to enter default mode.'
+-ExecStart=-/sbin/sulogin
+-ExecStopPost=/usr/bin/systemctl --fail --no-block default
++ExecStartPre=-/openslx/bin/plymouth quit
++ExecStartPre=-/openslx/bin/echo 'Welcome to emergency mode. Use "systemctl default" or ^D to enter default mode.'
++ExecStart=-/openslx/sbin/sulogin
++ExecStopPost=/openslx/usr/bin/systemctl --fail --no-block default
+ Type=idle
+ StandardInput=tty-force
+ StandardOutput=inherit
+diff -wur systemd-185/units/emergency.service.in systemd-185.openslx/units/emergency.service.in
+--- systemd-185/units/emergency.service.in 2012-05-21 19:23:02.768293222 +0200
++++ systemd-185.openslx/units/emergency.service.in 2012-06-25 20:02:25.391678536 +0200
+@@ -14,9 +14,9 @@
+ [Service]
+ Environment=HOME=/root
+ WorkingDirectory=/root
+-ExecStartPre=-/bin/plymouth quit
+-ExecStartPre=-/bin/echo 'Welcome to emergency mode. Use "systemctl default" or ^D to enter default mode.'
+-ExecStart=-/sbin/sulogin
++ExecStartPre=-/openslx/bin/plymouth quit
++ExecStartPre=-/openslx/bin/echo 'Welcome to emergency mode. Use "systemctl default" or ^D to enter default mode.'
++ExecStart=-/openslx/sbin/sulogin
+ ExecStopPost=@SYSTEMCTL@ --fail --no-block default
+ Type=idle
+ StandardInput=tty-force
+diff -wur systemd-185/units/getty@.service.m4 systemd-185.openslx/units/getty@.service.m4
+--- systemd-185/units/getty@.service.m4 2012-05-21 19:23:02.769293222 +0200
++++ systemd-185.openslx/units/getty@.service.m4 2012-06-25 19:31:46.471689522 +0200
+@@ -41,7 +41,7 @@
+
+ [Service]
+ Environment=TERM=linux
+-ExecStart=-/sbin/agetty %I 38400
++ExecStart=-/openslx/sbin/getty -L %I 115200 vt100
+ Type=idle
+ Restart=always
+ RestartSec=0
+diff -wur systemd-185/units/plymouth-halt.service systemd-185.openslx/units/plymouth-halt.service
+--- systemd-185/units/plymouth-halt.service 2012-04-12 01:04:30.635222913 +0200
++++ systemd-185.openslx/units/plymouth-halt.service 2012-06-25 20:02:25.388345203 +0200
+@@ -13,6 +13,6 @@
+ ConditionKernelCommandLine=!plymouth.enable=0
+
+ [Service]
+-ExecStart=/sbin/plymouthd --mode=shutdown
+-ExecStartPost=-/bin/plymouth --show-splash
++ExecStart=/openslx/sbin/plymouthd --mode=shutdown
++ExecStartPost=-/openslx/bin/plymouth --show-splash
+ Type=forking
+diff -wur systemd-185/units/plymouth-kexec.service systemd-185.openslx/units/plymouth-kexec.service
+--- systemd-185/units/plymouth-kexec.service 2012-04-12 01:04:30.635222913 +0200
++++ systemd-185.openslx/units/plymouth-kexec.service 2012-06-25 20:02:25.391678536 +0200
+@@ -13,6 +13,6 @@
+ ConditionKernelCommandLine=!plymouth.enable=0
+
+ [Service]
+-ExecStart=/sbin/plymouthd --mode=shutdown
+-ExecStartPost=-/bin/plymouth --show-splash
++ExecStart=/openslx/sbin/plymouthd --mode=shutdown
++ExecStartPost=-/openslx/bin/plymouth --show-splash
+ Type=forking
+diff -wur systemd-185/units/plymouth-poweroff.service systemd-185.openslx/units/plymouth-poweroff.service
+--- systemd-185/units/plymouth-poweroff.service 2012-04-12 01:04:30.635222913 +0200
++++ systemd-185.openslx/units/plymouth-poweroff.service 2012-06-25 20:02:25.391678536 +0200
+@@ -13,6 +13,6 @@
+ ConditionKernelCommandLine=!plymouth.enable=0
+
+ [Service]
+-ExecStart=/sbin/plymouthd --mode=shutdown
+-ExecStartPost=-/bin/plymouth --show-splash
++ExecStart=/openslx/sbin/plymouthd --mode=shutdown
++ExecStartPost=-/openslx/bin/plymouth --show-splash
+ Type=forking
+diff -wur systemd-185/units/plymouth-quit.service systemd-185.openslx/units/plymouth-quit.service
+--- systemd-185/units/plymouth-quit.service 2012-05-14 14:34:12.817358222 +0200
++++ systemd-185.openslx/units/plymouth-quit.service 2012-06-25 20:02:25.391678536 +0200
+@@ -10,6 +10,6 @@
+ After=rc-local.service plymouth-start.service systemd-user-sessions.service
+
+ [Service]
+-ExecStart=-/bin/plymouth quit
++ExecStart=-/openslx/bin/plymouth quit
+ Type=oneshot
+ TimeoutSec=20
+diff -wur systemd-185/units/plymouth-quit-wait.service systemd-185.openslx/units/plymouth-quit-wait.service
+--- systemd-185/units/plymouth-quit-wait.service 2012-05-14 14:34:12.817358222 +0200
++++ systemd-185.openslx/units/plymouth-quit-wait.service 2012-06-25 20:02:25.391678536 +0200
+@@ -10,6 +10,6 @@
+ After=rc-local.service plymouth-start.service systemd-user-sessions.service
+
+ [Service]
+-ExecStart=-/bin/plymouth --wait
++ExecStart=-/openslx/bin/plymouth --wait
+ Type=oneshot
+ TimeoutSec=20
+diff -wur systemd-185/units/plymouth-read-write.service systemd-185.openslx/units/plymouth-read-write.service
+--- systemd-185/units/plymouth-read-write.service 2012-04-12 01:04:30.635222913 +0200
++++ systemd-185.openslx/units/plymouth-read-write.service 2012-06-25 20:02:25.391678536 +0200
+@@ -12,5 +12,5 @@
+ Before=sysinit.target
+
+ [Service]
+-ExecStart=-/bin/plymouth update-root-fs --read-write
++ExecStart=-/openslx/bin/plymouth update-root-fs --read-write
+ Type=oneshot
+diff -wur systemd-185/units/plymouth-reboot.service systemd-185.openslx/units/plymouth-reboot.service
+--- systemd-185/units/plymouth-reboot.service 2012-04-12 01:04:30.635222913 +0200
++++ systemd-185.openslx/units/plymouth-reboot.service 2012-06-25 20:02:25.391678536 +0200
+@@ -13,6 +13,6 @@
+ ConditionKernelCommandLine=!plymouth.enable=0
+
+ [Service]
+-ExecStart=/sbin/plymouthd --mode=shutdown
+-ExecStartPost=-/bin/plymouth --show-splash
++ExecStart=/openslx/sbin/plymouthd --mode=shutdown
++ExecStartPost=-/openslx/bin/plymouth --show-splash
+ Type=forking
+diff -wur systemd-185/units/plymouth-start.service systemd-185.openslx/units/plymouth-start.service
+--- systemd-185/units/plymouth-start.service 2012-05-29 22:32:35.869895860 +0200
++++ systemd-185.openslx/units/plymouth-start.service 2012-06-25 20:02:25.391678536 +0200
+@@ -17,6 +17,6 @@
+ ConditionKernelCommandLine=!plymouth.enable=0
+
+ [Service]
+-ExecStart=/sbin/plymouthd --mode=boot --pid-file=/run/plymouth/pid
+-ExecStartPost=-/bin/plymouth --show-splash
++ExecStart=/openslx/sbin/plymouthd --mode=boot --pid-file=/run/plymouth/pid
++ExecStartPost=-/openslx/bin/plymouth --show-splash
+ Type=forking
+diff -wur systemd-185/units/quotacheck.service.in systemd-185.openslx/units/quotacheck.service.in
+--- systemd-185/units/quotacheck.service.in 2012-04-24 17:37:54.487812040 +0200
++++ systemd-185.openslx/units/quotacheck.service.in 2012-06-25 20:02:25.391678536 +0200
+@@ -10,7 +10,7 @@
+ DefaultDependencies=no
+ After=systemd-readahead-collect.service systemd-readahead-replay.service systemd-remount-fs.service
+ Before=local-fs.target shutdown.target
+-ConditionPathExists=/sbin/quotacheck
++ConditionPathExists=/openslx/sbin/quotacheck
+
+ [Service]
+ Type=oneshot
+diff -wur systemd-185/units/quotaon.service systemd-185.openslx/units/quotaon.service
+--- systemd-185/units/quotaon.service 2012-04-12 01:04:30.636222913 +0200
++++ systemd-185.openslx/units/quotaon.service 2012-06-25 20:02:25.391678536 +0200
+@@ -10,9 +10,9 @@
+ DefaultDependencies=no
+ After=systemd-readahead-collect.service systemd-readahead-replay.service quotacheck.service
+ Before=local-fs.target shutdown.target
+-ConditionPathExists=/sbin/quotaon
++ConditionPathExists=/openslx/sbin/quotaon
+
+ [Service]
+ Type=oneshot
+ RemainAfterExit=yes
+-ExecStart=/sbin/quotaon -aug
++ExecStart=/openslx/sbin/quotaon -aug
+diff -wur systemd-185/units/rescue.service.m4.in systemd-185.openslx/units/rescue.service.m4.in
+--- systemd-185/units/rescue.service.m4.in 2012-05-22 16:54:33.753007201 +0200
++++ systemd-185.openslx/units/rescue.service.m4.in 2012-06-25 20:02:25.395011869 +0200
+@@ -15,21 +15,21 @@
+ [Service]
+ Environment=HOME=/root
+ WorkingDirectory=/root
+-ExecStartPre=-/bin/plymouth quit
+-ExecStartPre=-/bin/echo -e 'Welcome to rescue mode! Type "systemctl default" or ^D to enter default mode.\\nType "journalctl" to view system logs. Type "systemctl reboot" to reboot.'
++ExecStartPre=-/openslx/bin/plymouth quit
++ExecStartPre=-/openslx/bin/echo -e 'Welcome to rescue mode! Type "systemctl default" or ^D to enter default mode.\\nType "journalctl" to view system logs. Type "systemctl reboot" to reboot.'
+ m4_ifdef(`TARGET_FEDORA',
+ `EnvironmentFile=/etc/sysconfig/init
+-ExecStart=-/bin/bash -c "exec ${SINGLE}"',
++ExecStart=-/openslx/bin/bash -c "exec ${SINGLE}"',
+ m4_ifdef(`TARGET_MANDRIVA',
+ `EnvironmentFile=/etc/sysconfig/init
+-ExecStart=-/bin/bash -c "exec ${SINGLE}"',
++ExecStart=-/openslx/bin/bash -c "exec ${SINGLE}"',
+ m4_ifdef(`TARGET_MAGEIA',
+ `EnvironmentFile=/etc/sysconfig/init
+-ExecStart=-/bin/bash -c "exec ${SINGLE}"',
++ExecStart=-/openslx/bin/bash -c "exec ${SINGLE}"',
+ m4_ifdef(`TARGET_MEEGO',
+ `EnvironmentFile=/etc/sysconfig/init
+-ExecStart=-/bin/bash -c "exec ${SINGLE}"',
+-`ExecStart=-/sbin/sulogin'))))
++ExecStart=-/openslx/bin/bash -c "exec ${SINGLE}"',
++`ExecStart=-/openslx/sbin/sulogin'))))
+ ExecStopPost=-@SYSTEMCTL@ --fail --no-block default
+ Type=idle
+ StandardInput=tty-force
+diff -wur systemd-185/units/serial-getty@.service.m4 systemd-185.openslx/units/serial-getty@.service.m4
+--- systemd-185/units/serial-getty@.service.m4 2012-05-21 19:23:02.773293222 +0200
++++ systemd-185.openslx/units/serial-getty@.service.m4 2012-06-25 19:32:10.101689381 +0200
+@@ -37,7 +37,7 @@
+
+ [Service]
+ Environment=TERM=vt102
+-ExecStart=-/sbin/agetty -s %I 115200,38400,9600
++ExecStart=-/openslx/sbin/getty -L %I 115200 vt100
+ Type=idle
+ Restart=always
+ RestartSec=0
+diff -wur systemd-185/units/systemd-readahead-drop.service systemd-185.openslx/units/systemd-readahead-drop.service
+--- systemd-185/units/systemd-readahead-drop.service 2012-05-23 04:10:44.080608263 +0200
++++ systemd-185.openslx/units/systemd-readahead-drop.service 2012-06-25 20:02:25.391678536 +0200
+@@ -11,7 +11,7 @@
+
+ [Service]
+ Type=oneshot
+-ExecStart=/bin/rm -f /.readahead
++ExecStart=/openslx/bin/rm -f /.readahead
+
+ [Install]
+ WantedBy=system-update.target
+diff -wur systemd-185/units/systemd-udev-settle.service systemd-185.openslx/units/systemd-udev-settle.service
+--- systemd-185/units/systemd-udev-settle.service 2012-06-04 20:17:02.951457265 +0200
++++ systemd-185.openslx/units/systemd-udev-settle.service 2012-06-25 20:02:25.391678536 +0200
+@@ -29,7 +29,7 @@
+ Type=oneshot
+ TimeoutSec=180
+ RemainAfterExit=yes
+-ExecStart=/usr/bin/udevadm settle
++ExecStart=/openslx/usr/bin/udevadm settle
+
+ [Install]
+ WantedBy=basic.target
+diff -wur systemd-185/units/systemd-udev-trigger.service systemd-185.openslx/units/systemd-udev-trigger.service
+--- systemd-185/units/systemd-udev-trigger.service 2012-06-04 20:17:02.933457272 +0200
++++ systemd-185.openslx/units/systemd-udev-trigger.service 2012-06-25 20:02:25.391678536 +0200
+@@ -17,4 +17,4 @@
+ [Service]
+ Type=oneshot
+ RemainAfterExit=yes
+-ExecStart=/usr/bin/udevadm trigger --type=subsystems --action=add ; /usr/bin/udevadm trigger --type=devices --action=add
++ExecStart=/openslx/usr/bin/udevadm trigger --type=subsystems --action=add ; /openslx/usr/bin/udevadm trigger --type=devices --action=add
diff --git a/package/systemd/systemd-uclibc-fix.patch b/package/systemd/systemd-uclibc-fix.patch
deleted file mode 100644
index 9a208450a..000000000
--- a/package/systemd/systemd-uclibc-fix.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-[PATCH] fix build with uClibc
-
-Based on OE patch from Khem Raj:
-
-http://cgit.openembedded.org/meta-openembedded/tree/meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch
-
-But extended to also cover execvpe (OE carries a patch adding execvpe
-support to uClibc).
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- src/journal/journal-file.c | 2 ++
- src/macro.h | 15 +++++++++++++++
- 2 files changed, 17 insertions(+)
-
-Index: systemd-44/src/macro.h
-===================================================================
---- systemd-44.orig/src/macro.h
-+++ systemd-44/src/macro.h
-@@ -28,6 +28,21 @@
- #include <sys/uio.h>
- #include <inttypes.h>
-
-+#ifdef __UCLIBC__
-+/* uclibc does not implement mkostemp GNU extension */
-+#define mkostemp(x,y) mkstemp(x)
-+/* uclibc does not implement execvpe GNU extension */
-+#ifndef _GNU_SOURCE
-+#define _GNU_SOURCE
-+#endif
-+#include <unistd.h>
-+static inline int execvpe(const char *file, char *const argv[],
-+ char *const envp[])
-+{
-+ environ = (char **)envp;
-+ return execvp(file, argv);
-+}
-+#endif
- #define _printf_attr_(a,b) __attribute__ ((format (printf, a, b)))
- #define _sentinel_ __attribute__ ((sentinel))
- #define _noreturn_ __attribute__((noreturn))
-Index: systemd-44/src/journal/journal-file.c
-===================================================================
---- systemd-44.orig/src/journal/journal-file.c
-+++ systemd-44/src/journal/journal-file.c
-@@ -229,11 +229,13 @@
- }
- }
-
-+#ifndef __UCLIBC__
- /* Note that the glibc fallocate() fallback is very
- inefficient, hence we try to minimize the allocation area
- as we can. */
- if (posix_fallocate(f->fd, old_size, new_size - old_size) < 0)
- return -errno;
-+#endif
-
- if (fstat(f->fd, &f->last_stat) < 0)
- return -errno;
diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index 696a3a721..3dc007621 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -3,7 +3,7 @@
# systemd
#
#############################################################
-SYSTEMD_VERSION = 44
+SYSTEMD_VERSION = 185
SYSTEMD_SITE = http://www.freedesktop.org/software/systemd/
SYSTEMD_SOURCE = systemd-$(SYSTEMD_VERSION).tar.xz
SYSTEMD_INSTALL_STAGING = YES