summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Korsgaard2008-10-20 13:32:25 +0200
committerPeter Korsgaard2008-10-20 13:32:25 +0200
commit886b274a5cbe66f470867004a73384451b140c19 (patch)
tree9b7ba18a4996357f10c9939aad65fa4f87ba5e53
parentMakefile.autotools.in: default to install-strip for non-debug target install (diff)
downloadbuildroot-886b274a5cbe66f470867004a73384451b140c19.tar.gz
buildroot-886b274a5cbe66f470867004a73384451b140c19.tar.xz
buildroot-886b274a5cbe66f470867004a73384451b140c19.zip
BR2_HAVE_DOCUMENTATION: add option to remove documentation from target
Some packages' install-strip target install quite big documentation, so create an option to remove it similar to the existing man/info options.
-rw-r--r--Config.in7
-rw-r--r--package/Makefile.autotools.in3
2 files changed, 10 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index 32a154bc3..ddbe43b9a 100644
--- a/Config.in
+++ b/Config.in
@@ -348,6 +348,13 @@ config BR2_HAVE_INFOPAGES
If you say n here, your target will not contain any
infopage.
+config BR2_HAVE_DOCUMENTATION
+ bool "documentation on the target"
+ help
+ Leave the documentation on the target.
+ If you say n here, your target will not contain any
+ documentation.
+
config BR2_HAVE_DEVFILES
bool "development files in target filesystem"
help
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 0925feb06..9f7a54807 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -256,6 +256,9 @@ $(PROJECT_BUILD_DIR)/autotools-stamps/%_target_installed:
$(if $(BR2_HAVE_INFOPAGES),,for d in info share/info; do \
rm -rf $(TARGET_DIR)/$$d $(TARGET_DIR)/usr/$$d; \
done)
+ $(if $(BR2_HAVE_DOCUMENTATION),,for d in doc share/doc; do \
+ rm -rf $(TARGET_DIR)/$$d $(TARGET_DIR)/usr/$$d; \
+ done)
$(Q)mkdir -p $(@D)
touch $@