summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni2010-08-21 17:21:40 +0200
committerThomas Petazzoni2010-09-01 12:26:56 +0200
commit8b6585a9d3adf35179c988a10edd16ffc2c15346 (patch)
tree4f3e824fb1d7600b88bab15dfd690970f95a0686
parentBump package/config to 2.6.36-rc1 (diff)
downloadbuildroot-8b6585a9d3adf35179c988a10edd16ffc2c15346.tar.gz
buildroot-8b6585a9d3adf35179c988a10edd16ffc2c15346.tar.xz
buildroot-8b6585a9d3adf35179c988a10edd16ffc2c15346.zip
Add support for the new nconf configuration tool
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--Makefile10
-rw-r--r--package/config/Makefile3
-rw-r--r--package/config/patches/06-br-build-system-integration.patch19
3 files changed, 25 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 73d9335c2..fd4697213 100644
--- a/Makefile
+++ b/Makefile
@@ -28,7 +28,7 @@ CONFIG_CONFIG_IN=Config.in
CONFIG=package/config
DATE:=$(shell date +%Y%m%d)
-noconfig_targets:=menuconfig gconfig xconfig config oldconfig randconfig \
+noconfig_targets:=menuconfig nconfig gconfig xconfig config oldconfig randconfig \
defconfig %_defconfig allyesconfig allnoconfig release \
randpackageconfig allyespackageconfig allnopackageconfig \
source-check help
@@ -490,6 +490,14 @@ menuconfig: $(BUILD_DIR)/buildroot-config/mconf
test -f $(CONFIG_DIR)/.config.cmd || rm -f $(CONFIG_DIR)/.config; \
fi
+nconfig: $(BUILD_DIR)/buildroot-config/nconf
+ @mkdir -p $(BUILD_DIR)/buildroot-config
+ @if ! KCONFIG_AUTOCONFIG=$(BUILD_DIR)/buildroot-config/auto.conf \
+ KCONFIG_AUTOHEADER=$(BUILD_DIR)/buildroot-config/autoconf.h \
+ BUILDROOT_CONFIG=$(CONFIG_DIR)/.config $< $(CONFIG_CONFIG_IN); then \
+ test -f $(CONFIG_DIR)/.config.cmd || rm -f $(CONFIG_DIR)/.config; \
+ fi
+
config: $(BUILD_DIR)/buildroot-config/conf
@mkdir -p $(BUILD_DIR)/buildroot-config
@KCONFIG_AUTOCONFIG=$(BUILD_DIR)/buildroot-config/auto.conf \
diff --git a/package/config/Makefile b/package/config/Makefile
index 7e199bc9d..d8d44b042 100644
--- a/package/config/Makefile
+++ b/package/config/Makefile
@@ -177,6 +177,9 @@ hostprogs-y := conf qconf gconf kxgettext
ifeq ($(MAKECMDGOALS),nconfig)
hostprogs-y += nconf
endif
+ifeq ($(findstring nconf,$(MAKECMDGOALS)),nconf)
+ hostprogs-y += nconf
+endif
ifeq ($(MAKECMDGOALS),menuconfig)
hostprogs-y += mconf
diff --git a/package/config/patches/06-br-build-system-integration.patch b/package/config/patches/06-br-build-system-integration.patch
index a2e634ffd..128bbc02c 100644
--- a/package/config/patches/06-br-build-system-integration.patch
+++ b/package/config/patches/06-br-build-system-integration.patch
@@ -1,12 +1,19 @@
---
- Makefile | 11 ++++++++++-
- 1 file changed, 10 insertions(+), 1 deletion(-)
+ Makefile | 14 +++++++++++++-
+ 1 file changed, 13 insertions(+), 1 deletion(-)
-Index: config.new/Makefile
+Index: config/Makefile
===================================================================
---- config.new.orig/Makefile
-+++ config.new/Makefile
-@@ -181,14 +181,23 @@
+--- config.orig/Makefile
++++ config/Makefile
+@@ -177,18 +177,30 @@
+ ifeq ($(MAKECMDGOALS),nconfig)
+ hostprogs-y += nconf
+ endif
++ifeq ($(findstring nconf,$(MAKECMDGOALS)),nconf)
++ hostprogs-y += nconf
++endif
+
ifeq ($(MAKECMDGOALS),menuconfig)
hostprogs-y += mconf
endif