summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Zacarias2011-01-17 13:13:42 +0100
committerPeter Korsgaard2011-01-19 17:19:42 +0100
commit9bc58a42af830ecccfdb6c1d4f837356567c6386 (patch)
tree11aa5b45b1a9104b37ee18cffceb0bb61c82db75
parentbusybox: add 1.18.2 fixes (diff)
downloadbuildroot-9bc58a42af830ecccfdb6c1d4f837356567c6386.tar.gz
buildroot-9bc58a42af830ecccfdb6c1d4f837356567c6386.tar.xz
buildroot-9bc58a42af830ecccfdb6c1d4f837356567c6386.zip
toolchain: only fetch gcc/gmp/mpfr/mpc when using a buildroot toolchain
Closes #3103 gcc/gmp/mpfr/mpc are only needed when using an internal buildroot toolchain, so only add them to HOST_SOURCE then. Otherwise we get some nasty fetch error when doing "make source" [Peter: add gmpc/mpfr/mpc and reword commit text] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES1
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk6
2 files changed, 7 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index baddfadc7..a8255117f 100644
--- a/CHANGES
+++ b/CHANGES
@@ -44,6 +44,7 @@
#2965: Broken linkage to xkbcomp (blocking X server startup)
#2983: xlib_libX11 build failed
#3007: kexec doesn't build: Missing regdef.h file
+ #3103: make external-deps wants to download gcc-.tar.bz2 when...
#3109: abnormal `make busybox-menuconfig`
2010.11, Released November 30th, 2010:
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 80bed5eff..2c857dce5 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -109,12 +109,16 @@ endif
GCC_WITH_HOST_GMP = --with-gmp=$(HOST_DIR)/usr
GCC_WITH_HOST_MPFR = --with-mpfr=$(HOST_DIR)/usr
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
HOST_SOURCE += host-gmp-source host-mpfr-source
+endif
GCC_HOST_PREREQ = host-gmp host-mpfr
ifeq ($(findstring x4.5.,x$(GCC_VERSION)),x4.5.)
GCC_WITH_HOST_MPC = --with-mpc=$(HOST_DIR)/usr
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
HOST_SOURCE += host-mpc-source
+endif
GCC_HOST_PREREQ += host-mpc
endif
@@ -152,7 +156,9 @@ GCC_CONF_ENV:=acx_cv_prog_cc_pedantic__Wno_long_long__Wno_variadic_macros_______
acx_cv_prog_cc_warning__Wno_overlength_strings=no
endif
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
HOST_SOURCE+=gcc-source
+endif
$(DL_DIR)/$(GCC_SOURCE):
mkdir -p $(DL_DIR)