summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Schmelzer2012-06-26 15:04:39 +0200
committerSebastian Schmelzer2012-06-26 15:04:39 +0200
commita0c582af0709f0bc213371138dc385205609d316 (patch)
tree44f023f5435f3f22bb7d42d0af44182ecbde8b1b
parentminor systemd fixes, buildroot cfg without x11 (diff)
downloadbuildroot-a0c582af0709f0bc213371138dc385205609d316.tar.gz
buildroot-a0c582af0709f0bc213371138dc385205609d316.tar.xz
buildroot-a0c582af0709f0bc213371138dc385205609d316.zip
minor systemd fixes
-rw-r--r--package/systemd/systemd.mk17
1 files changed, 6 insertions, 11 deletions
diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index 885e3f177..01ad64233 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -21,18 +21,13 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
endif
SYSTEMD_CONF_OPT += \
+ --exec-prefix=/openslx \
--with-distro=other \
- --disable-selinux \
- --disable-pam \
- --disable-libcryptsetup \
- --disable-gtk \
- --disable-plymouth \
- --with-rootdir=/ \
+ --enable-plymouth \
--with-dbuspolicydir=/etc/dbus-1/system.d \
--with-dbussessionservicedir=/usr/share/dbus-1/services \
--with-dbussystemservicedir=/usr/share/dbus-1/system-services \
--with-dbusinterfacedir=/usr/share/dbus-1/interfaces \
- --with-udevrulesdir=/etc/udev/rules.d \
--with-sysvinit-path=/etc/init.d/ \
--without-sysvrcd-path \
--enable-split-usr
@@ -54,11 +49,11 @@ SYSTEMD_MAKE_OPT += LDFLAGS+=-ldl
define SYSTEMD_INSTALL_INIT_HOOK
ln -fs ../usr/lib/systemd/systemd $(TARGET_DIR)/sbin/init
- ln -fs ../usr/bin/systemctl $(TARGET_DIR)/sbin/halt
- ln -fs ../usr/bin/systemctl $(TARGET_DIR)/sbin/poweroff
- ln -fs ../usr/bin/systemctl $(TARGET_DIR)/sbin/reboot
+ ln -fs ../usr/bin/systemctl $(TARGET_DIR)/openslx/sbin/halt
+ ln -fs ../usr/bin/systemctl $(TARGET_DIR)/openslx/sbin/poweroff
+ ln -fs ../usr/bin/systemctl $(TARGET_DIR)/openslx/sbin/reboot
- ln -fs ../../../usr/lib/systemd/system/multi-user.target $(TARGET_DIR)/etc/systemd/system/default.target
+ ln -fs ../../../usr/lib/systemd/system/getty.target $(TARGET_DIR)/etc/systemd/system/default.target
endef
define SYSTEMD_INSTALL_TTY_HOOK