summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wickham2011-02-04 19:45:46 +0100
committerPeter Korsgaard2011-02-04 19:46:45 +0100
commitc18c1d667afb3cdc1e1cd177a4b2d5ad77203731 (patch)
tree7120fd92feac8374d8e625ce8e2bf68f6b265298
parentsawman: bump version (diff)
downloadbuildroot-c18c1d667afb3cdc1e1cd177a4b2d5ad77203731.tar.gz
buildroot-c18c1d667afb3cdc1e1cd177a4b2d5ad77203731.tar.xz
buildroot-c18c1d667afb3cdc1e1cd177a4b2d5ad77203731.zip
python: fix modules_lib_dirs typo in patch-2.7-005-stagng-headers-libs.patch
Closes #3169 Typo in modules_lib_dirs section of patch specified modules_include_dirs instead of modules_lib_dirs. This matters if PYTHON_MODULES_LIB is not passed into the script. Signed-off-by: Mark Wickham <markw@digi.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES1
-rw-r--r--package/python/python-2.7-005-staging-headers-libs.patch2
2 files changed, 2 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index f3293dc30..61a51fbbb 100644
--- a/CHANGES
+++ b/CHANGES
@@ -97,6 +97,7 @@
#3103: make external-deps wants to download gcc-.tar.bz2 when...
#3109: abnormal `make busybox-menuconfig`
#3115: How about board specific makefiles?
+ #3169: python patch has typo, aborts build in scenario
#3181: dhcp.mk copies S80dhcp-server to etc/init.d, not etc/init.d/
2010.11, Released November 30th, 2010:
diff --git a/package/python/python-2.7-005-staging-headers-libs.patch b/package/python/python-2.7-005-staging-headers-libs.patch
index ab3d88e73..170e81970 100644
--- a/package/python/python-2.7-005-staging-headers-libs.patch
+++ b/package/python/python-2.7-005-staging-headers-libs.patch
@@ -27,7 +27,7 @@ Index: Python-2.7.1/setup.py
+ try:
+ modules_lib_dirs = os.environ["PYTHON_MODULES_LIB"].split()
+ except KeyError:
-+ modules_include_dirs = ['/usr/lib']
++ modules_lib_dirs = ['/usr/lib']
+ for dir in modules_include_dirs:
+ add_dir_to_list(self.compiler.include_dirs, dir)
+ for dir in modules_lib_dirs: