summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2005-12-10 15:59:02 +0100
committerBernhard Reutner-Fischer2005-12-10 15:59:02 +0100
commitce90aae17c62b270d69b70811097d018907ff833 (patch)
tree61c545934fa7a206611e97bb0d2e998974c5e7df
parent- add terse helptext (diff)
downloadbuildroot-ce90aae17c62b270d69b70811097d018907ff833.tar.gz
buildroot-ce90aae17c62b270d69b70811097d018907ff833.tar.xz
buildroot-ce90aae17c62b270d69b70811097d018907ff833.zip
- add option to pass to tar for unpacking the source.
Set it to exclude .svn per default (please default to "" if inappropriate)
-rw-r--r--Config.in4
-rw-r--r--Makefile6
2 files changed, 8 insertions, 2 deletions
diff --git a/Config.in b/Config.in
index 8714bc633..f62f9c973 100644
--- a/Config.in
+++ b/Config.in
@@ -125,6 +125,10 @@ config BR2_TAR_VERBOSITY
bool "Tar verbose"
default n
+config BR2_TAR_OPTIONS
+ string "Tar options"
+ default "--exclude='.svn'"
+
config BR2_DL_DIR
string "Download dir"
default "$(BASE_DIR)/dl"
diff --git a/Makefile b/Makefile
index 5d8f72599..629129603 100644
--- a/Makefile
+++ b/Makefile
@@ -36,9 +36,11 @@ ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
endif
ifeq ($(BR2_TAR_VERBOSITY),y)
-TAR_OPTIONS=-xvf
+TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xvf
+#"
else
-TAR_OPTIONS=-xf
+TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
+#"
endif
ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)