summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind)2012-02-14 10:56:52 +0100
committerPeter Korsgaard2012-02-14 12:07:27 +0100
commitcf2486bf317e4bbf88c801fb96183ba62be78cc8 (patch)
tree1de3b61198f33d1845d3c86dfa7e8f6e54cd672e
parentzlib: bump version (diff)
downloadbuildroot-cf2486bf317e4bbf88c801fb96183ba62be78cc8.tar.gz
buildroot-cf2486bf317e4bbf88c801fb96183ba62be78cc8.tar.xz
buildroot-cf2486bf317e4bbf88c801fb96183ba62be78cc8.zip
DOWNLOAD_WGET: use -O instead of -P to set output file
Some URLs use url-encoded arguments to specify the file to download. Wget will then use an output file name which includes all the ampersands and such. However, this is not what we see from buildroot. E.g.: FOO_SITE="http://git.foo.com/?p=foo.git;a=blob;f=" FOO_SOURCE="foo.tgz" wget will download this into $(DL_DIR)/index.html?p=foo.git;a=blob;f=foo.tgz buildroot thinks it's in $(DL_DIR)/foo.tgz To make sure the view of wget and buildroot are consistent, specify the output file explicitly. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/Makefile.package.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 33461b4dc..ea44c6cef 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -238,7 +238,7 @@ endef
define DOWNLOAD_WGET
test -e $(DL_DIR)/$(2) || \
- $(WGET) -P $(DL_DIR) $(call qstrip,$(1))/$(2)
+ $(WGET) -O $(DL_DIR)/$(2) $(call qstrip,$(1))/$(2)
endef
define SOURCE_CHECK_WGET