summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni2009-06-25 10:43:24 +0200
committerThomas Petazzoni2009-07-03 10:30:29 +0200
commitd4dab10d0b2e770be63348e9ff58b9ba195d1b5c (patch)
treeae076907cc01550678abbdf74ca01f5a2c8ab268
parentCHANGES: add issue 349 + 379 (diff)
downloadbuildroot-d4dab10d0b2e770be63348e9ff58b9ba195d1b5c.tar.gz
buildroot-d4dab10d0b2e770be63348e9ff58b9ba195d1b5c.tar.xz
buildroot-d4dab10d0b2e770be63348e9ff58b9ba195d1b5c.zip
Fix Qtopia build with external toolchain
The fixes made to qmake.conf for the cross-compiling tools were not sufficient in the case of an external toolchain, since the CFLAGS were not taken into account. And the --sysroot option contained in the CFLAGS are very important for external toolchains to work. Additionally, it makes sure that Qtopia is compiled with the proper CFLAGS, even if an external toolchain isn't used.
-rw-r--r--package/qtopia4/qtopia4.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index a198a41bd..fb027dcee 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -440,6 +440,8 @@ endif
$(call QTOPIA4_QMAKE_SET,OBJCOPY,$(TARGET_OBJCOPY))
$(call QTOPIA4_QMAKE_SET,RANLIB,$(TARGET_RANLIB))
$(call QTOPIA4_QMAKE_SET,STRIP,$(TARGET_STRIP))
+ $(call QTOPIA4_QMAKE_SET,CFLAGS,$(TARGET_CFLAGS))
+ $(call QTOPIA4_QMAKE_SET,CXXFLAGS,$(TARGET_CXXFLAGS))
-[ -f $(QTOPIA4_QCONFIG_FILE) ] && cp $(QTOPIA4_QCONFIG_FILE) \
$(QTOPIA4_TARGET_DIR)/$(QTOPIA4_QCONFIG_FILE_LOCATION)
# Qt doesn't use PKG_CONFIG, it searches for pkg-config with 'which'.