summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Frysinger2005-09-18 06:41:57 +0200
committerMike Frysinger2005-09-18 06:41:57 +0200
commite4de8b2f1414965ca2989eb3a90094ae5ff2224f (patch)
tree88b192b4990ee1144f8bdd4a609d28d29182057e
parentAdd patches for latest snapshot of gdb. The starting point was the 6.3 (diff)
downloadbuildroot-e4de8b2f1414965ca2989eb3a90094ae5ff2224f.tar.gz
buildroot-e4de8b2f1414965ca2989eb3a90094ae5ff2224f.tar.xz
buildroot-e4de8b2f1414965ca2989eb3a90094ae5ff2224f.zip
add sf mirrors list in help (fix by Bernhard Fischer) and allow people to add custom prefix/suffix to builds
-rw-r--r--Config.in25
-rw-r--r--package/Makefile.in14
2 files changed, 35 insertions, 4 deletions
diff --git a/Config.in b/Config.in
index 786b27581..e6ab609a6 100644
--- a/Config.in
+++ b/Config.in
@@ -100,7 +100,7 @@ config BR2_WGET
default "wget --passive-ftp -nd"
config BR2_SVN
- string "Subversion (svn) checkout command"
+ string "Subversion (svn) checkout command"
default "svn co"
config BR2_TAR_VERBOSITY
@@ -108,7 +108,7 @@ config BR2_TAR_VERBOSITY
default n
config BR2_SOURCEFORGE_MIRROR
- string "Sourceforge mirror site"
+ string "Sourceforge mirror site"
default "easynews"
help
Sourceforge has a system of mirror sites. Some sites may be closer
@@ -116,6 +116,9 @@ config BR2_SOURCEFORGE_MIRROR
available. This option allows you to select your preferred Sourceforge
mirror site.
+ The list of mirrors is available here:
+ http://prdownloads.sourceforge.net/index-sf.html?download
+
config BR2_STAGING_DIR
string "Toolchain and header file location?"
default "$(BUILD_DIR)/staging_dir"
@@ -129,6 +132,24 @@ config BR2_STAGING_DIR
Most people will leave this set to the default value of
"$(BUILD_DIR)/staging_dir".
+config BR2_TOPDIR_PREFIX
+ string "Custom build dir prefix"
+ default ""
+ help
+ Add a custom string to the beginning of the build directories.
+
+ build_ARCH -> [PREFIX]_build_ARCH
+ toolchain_build_ARCH -> [PREFIX]_toolchain_build_ARCH
+
+config BR2_TOPDIR_SUFFIX
+ string "Custom build dir suffix"
+ default ""
+ help
+ Add a custom string to the end of the build directories.
+
+ build_ARCH -> build_ARCH_[SUFFIX]
+ toolchain_build_ARCH -> toolchain_build_ARCH_[SUFFIX]
+
config BR2_JLEVEL
int "Number of jobs to run simultaneously"
default "1"
diff --git a/package/Makefile.in b/package/Makefile.in
index a81d469a1..297ecffd5 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -16,13 +16,23 @@ DISABLE_LARGEFILE= --disable-largefile
endif
TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING)
+TOPDIR_PREFIX:=$(strip $(subst ",, $(BR2_TOPDIR_PREFIX)))_
+TOPDIR_SUFFIX:=_$(strip $(subst ",, $(BR2_TOPDIR_SUFFIX)))
+ifeq ($(TOPDIR_PREFIX),_)
+TOPDIR_PREFIX:=
+endif
+ifeq ($(TOPDIR_SUFFIX),_)
+TOPDIR_SUFFIX:=
+endif
+
HOSTCC:=gcc
BASE_DIR:=${shell pwd}
DL_DIR:=$(BASE_DIR)/dl
#PATCH_DIR=$(BASE_DIR)/sources/patches
-BUILD_DIR:=$(BASE_DIR)/build_$(ARCH)$(ARCH_FPU_SUFFIX)
+BUILD_DIR:=$(BASE_DIR)/$(TOPDIR_PREFIX)build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_SUFFIX)
TARGET_DIR:=$(BUILD_DIR)/root
-TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build_$(ARCH)$(ARCH_FPU_SUFFIX)
+TOOL_BUILD_DIR=$(BASE_DIR)/$(TOPDIR_PREFIX)toolchain_build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_SUFFIX)
+
# Strip off the annoying quoting
STAGING_DIR:=$(strip $(subst ",, $(BR2_STAGING_DIR)))
#"