summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Newton2009-08-10 11:04:14 +0200
committerPeter Korsgaard2009-08-26 23:00:38 +0200
commitfc3eb18b70fe4a866790f958b958d4f18daf1f63 (patch)
treee84d6da4a73117bd940a8178900c92bf9b6d8afd
parentpackage/Makefile.in: use := for INSTALL (diff)
downloadbuildroot-fc3eb18b70fe4a866790f958b958d4f18daf1f63.tar.gz
buildroot-fc3eb18b70fe4a866790f958b958d4f18daf1f63.tar.xz
buildroot-fc3eb18b70fe4a866790f958b958d4f18daf1f63.zip
Makefile: Ensure CVS directories are removed from target fs.
The find command syntax is incorrect when deleting CVS and .svn directories from the target filesystem, which prevent CVS directories from being deleted. It's useful to delete these dirs because users of buildroot often import buildroot into CVS or Subversion. Signed-off-by: Will Newton <will.newton@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 182853ce9..568348494 100644
--- a/Makefile
+++ b/Makefile
@@ -337,7 +337,7 @@ $(PROJECT_BUILD_DIR)/.root:
fi; \
touch $(STAGING_DIR)/.fakeroot.00000; \
fi
- -find $(TARGET_DIR) -type d -name CVS -o -name .svn -print0 | xargs -0 rm -rf
+ -find $(TARGET_DIR) -type d -name CVS -print0 -o -name .svn -print0 | xargs -0 rm -rf
-find $(TARGET_DIR) -type f -name .empty -print0 | xargs -0 rm -rf
touch $@