summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2008-03-04 13:19:16 +0100
committerPeter Korsgaard2008-03-04 13:19:16 +0100
commit155971e08fb51a7e385d13c649a5651cf261f41b (patch)
tree35dd84bb45307791b39a48831580d246b23a1d7c /Makefile
parentdbus: start earlier (diff)
downloadbuildroot-155971e08fb51a7e385d13c649a5651cf261f41b.tar.gz
buildroot-155971e08fb51a7e385d13c649a5651cf261f41b.tar.xz
buildroot-155971e08fb51a7e385d13c649a5651cf261f41b.zip
buildroot: add external-deps target
Add external-deps target to show what external files are needed to recreate the build.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5ebf75eae..96436ef51 100644
--- a/Makefile
+++ b/Makefile
@@ -322,6 +322,10 @@ source: $(TARGETS_SOURCE) $(HOST_SOURCE)
_source-check:
$(MAKE) SPIDER=--spider source
+external-deps:
+ @$(MAKE) -Bs BR2_WGET=$(TOPDIR)toolchain/wget-show-external-deps.sh \
+ source
+
#############################################################
#
# Cleanup and misc junk
@@ -461,6 +465,7 @@ help:
@echo 'Miscellaneous:'
@echo ' source - download all sources needed for offline-build'
@echo ' source-check - check all packages for valid download URLs'
+ @echo ' external-deps - list external packages used'
@echo
@echo 'See docs/README and docs/buildroot.html for further details'
@echo