summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile5
-rwxr-xr-xtoolchain/wget-show-external-deps.sh6
2 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5ebf75eae..96436ef51 100644
--- a/Makefile
+++ b/Makefile
@@ -322,6 +322,10 @@ source: $(TARGETS_SOURCE) $(HOST_SOURCE)
_source-check:
$(MAKE) SPIDER=--spider source
+external-deps:
+ @$(MAKE) -Bs BR2_WGET=$(TOPDIR)toolchain/wget-show-external-deps.sh \
+ source
+
#############################################################
#
# Cleanup and misc junk
@@ -461,6 +465,7 @@ help:
@echo 'Miscellaneous:'
@echo ' source - download all sources needed for offline-build'
@echo ' source-check - check all packages for valid download URLs'
+ @echo ' external-deps - list external packages used'
@echo
@echo 'See docs/README and docs/buildroot.html for further details'
@echo
diff --git a/toolchain/wget-show-external-deps.sh b/toolchain/wget-show-external-deps.sh
new file mode 100755
index 000000000..20071c05f
--- /dev/null
+++ b/toolchain/wget-show-external-deps.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# replacement for wget (see BR2_WGET) which simply shows the file name to be
+# downloaded. Used by the external-deps make target.
+
+exec basename ${!#} \ No newline at end of file