summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Nyström2010-12-26 00:29:42 +0100
committerPeter Korsgaard2010-12-29 23:35:52 +0100
commit2bf3c1660965d73a553d3c99d6f1a62f36e0069b (patch)
treef0b68328b509431f27f49fab3f0315e100e090d9 /Makefile
parenttoolchain: drop BR2_CROSS_TOOLCHAIN_TARGET_UTILS option (diff)
downloadbuildroot-2bf3c1660965d73a553d3c99d6f1a62f36e0069b.tar.gz
buildroot-2bf3c1660965d73a553d3c99d6f1a62f36e0069b.tar.xz
buildroot-2bf3c1660965d73a553d3c99d6f1a62f36e0069b.zip
Reset critical environment variables
Reset them early in top-level Makefile to ensure they're keept unset all the way through the build process. This also removes the requirement of these variables being unset globally prior the build. Signed-off-by: Daniel Nyström <daniel.nystrom@timeterminal.se> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 9ba80a689..6d6e83630 100644
--- a/Makefile
+++ b/Makefile
@@ -186,6 +186,12 @@ cc-option=$(shell if $(TARGET_CC) $(TARGET_CFLAGS) $(1) -S -o /dev/null -xc /dev
#############################################################
unexport CROSS_COMPILE
unexport ARCH
+unexport CC
+unexport CXX
+unexport CPP
+unexport CFLAGS
+unexport CXXFLAGS
+unexport GREP_OPTIONS
GNU_HOST_NAME:=$(shell package/gnuconfig/config.guess)