summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile6
-rwxr-xr-xtoolchain/dependencies/dependencies.sh9
2 files changed, 6 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 9ba80a689..6d6e83630 100644
--- a/Makefile
+++ b/Makefile
@@ -186,6 +186,12 @@ cc-option=$(shell if $(TARGET_CC) $(TARGET_CFLAGS) $(1) -S -o /dev/null -xc /dev
#############################################################
unexport CROSS_COMPILE
unexport ARCH
+unexport CC
+unexport CXX
+unexport CPP
+unexport CFLAGS
+unexport CXXFLAGS
+unexport GREP_OPTIONS
GNU_HOST_NAME:=$(shell package/gnuconfig/config.guess)
diff --git a/toolchain/dependencies/dependencies.sh b/toolchain/dependencies/dependencies.sh
index c5552cae0..74ab2137a 100755
--- a/toolchain/dependencies/dependencies.sh
+++ b/toolchain/dependencies/dependencies.sh
@@ -4,15 +4,6 @@
export LC_ALL=C
-# Verify that critical environment variables aren't set
-for var in CC CXX CPP CFLAGS CXXFLAGS GREP_OPTIONS CROSS_COMPILE ARCH ; do
- if test -n "$(eval echo '$'$var)" ; then
- /bin/echo -e "\nYou must run 'unset $var' so buildroot can run with";
- /bin/echo -e "a clean environment on your build machine\n";
- exit 1;
- fi
-done
-
# Verify that grep works
echo "WORKS" | grep "WORKS" >/dev/null 2>&1
if test $? != 0 ; then