summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2009-04-06 11:21:22 +0200
committerPeter Korsgaard2009-04-06 11:21:22 +0200
commit4d298a2d3771c177da606e00b916f58be7c629a0 (patch)
tree0f4346ed7bab77c8d3e21692f72352249544dc61 /Makefile
parentncftp: cleanup Config.in (diff)
downloadbuildroot-4d298a2d3771c177da606e00b916f58be7c629a0.tar.gz
buildroot-4d298a2d3771c177da606e00b916f58be7c629a0.tar.xz
buildroot-4d298a2d3771c177da606e00b916f58be7c629a0.zip
Makefile: target-devfiles: combine .a / .la find invocation
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index b8676bf8a..b360626cd 100644
--- a/Makefile
+++ b/Makefile
@@ -331,7 +331,7 @@ $(PROJECT_BUILD_DIR)/.root:
touch $(STAGING_DIR)/.fakeroot.00000; \
fi
-find $(TARGET_DIR) -type d -name CVS -o -name .svn | xargs rm -rf
- -find $(TARGET_DIR) -type f -name .empty | xargs rm -rf
+ -find $(TARGET_DIR) -type f -name .empty | xargs rm -rf
touch $@
$(TARGET_DIR): $(PROJECT_BUILD_DIR)/.root
@@ -344,10 +344,8 @@ ifeq ($(BR2_HAVE_DEVFILES),y)
( scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )
else
rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/lib/pkgconfig
- find $(TARGET_DIR)/usr/lib -name '*.a' -delete
- find $(TARGET_DIR)/lib -name '*.a' -delete
- find $(TARGET_DIR)/usr/lib -name '*.la' -delete
- find $(TARGET_DIR)/lib -name '*.la' -delete
+ find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -delete
+ find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -delete
endif
source: $(TARGETS_SOURCE) $(HOST_SOURCE)