summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index b8676bf8a..b360626cd 100644
--- a/Makefile
+++ b/Makefile
@@ -331,7 +331,7 @@ $(PROJECT_BUILD_DIR)/.root:
touch $(STAGING_DIR)/.fakeroot.00000; \
fi
-find $(TARGET_DIR) -type d -name CVS -o -name .svn | xargs rm -rf
- -find $(TARGET_DIR) -type f -name .empty | xargs rm -rf
+ -find $(TARGET_DIR) -type f -name .empty | xargs rm -rf
touch $@
$(TARGET_DIR): $(PROJECT_BUILD_DIR)/.root
@@ -344,10 +344,8 @@ ifeq ($(BR2_HAVE_DEVFILES),y)
( scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )
else
rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/lib/pkgconfig
- find $(TARGET_DIR)/usr/lib -name '*.a' -delete
- find $(TARGET_DIR)/lib -name '*.a' -delete
- find $(TARGET_DIR)/usr/lib -name '*.la' -delete
- find $(TARGET_DIR)/lib -name '*.la' -delete
+ find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -delete
+ find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -delete
endif
source: $(TARGETS_SOURCE) $(HOST_SOURCE)