summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorUlf Samuelsson2008-07-05 11:22:38 +0200
committerUlf Samuelsson2008-07-05 11:22:38 +0200
commit50cbb4a1887c798753f7dbf0e228c1fe79a16ce3 (patch)
treee9e612c5f0116f1f2a1fa82792dd2d56db4cd5fd /Makefile
parent[0002974] add support for zlib and bzip2 in lighttpd, use alphabetical order ... (diff)
downloadbuildroot-50cbb4a1887c798753f7dbf0e228c1fe79a16ce3.tar.gz
buildroot-50cbb4a1887c798753f7dbf0e228c1fe79a16ce3.tar.xz
buildroot-50cbb4a1887c798753f7dbf0e228c1fe79a16ce3.zip
Add configuration possibility for host Gnome Lib installation
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index f57d1f396..8255771ca 100644
--- a/Makefile
+++ b/Makefile
@@ -36,7 +36,7 @@ noconfig_targets:=menuconfig config oldconfig randconfig \
ifneq ($(BUILDROOT_LOCAL),)
BR2_LOCAL:=$(BUILDROOT_LOCAL)
else
-BR2_LOCAL:=$(TOPDIR)/local
+BR2_LOCAL:=$(TOPDIR)local
endif
# $(shell find . -name *_defconfig |sed 's/.*\///')
@@ -57,6 +57,12 @@ BR2_DL_DIR:=$(BUILDROOT_DL_DIR)
endif
LOCAL:=$(BR2_LOCAL)
+ifneq ($(BUILDROOT_HOST_GLIB),)
+HOST_GLIB:=$(BUILDROOT_HOST_GLIB)
+else
+HOST_GLIB:=$(BR2_HOST_GLIB)
+endif
+
# To put more focus on warnings, be less verbose as default
# Use 'make V=1' to see the full commands
ifdef V
@@ -511,4 +517,8 @@ help:
.PHONY: dummy subdirs release distclean clean config oldconfig \
menuconfig tags check test depend defconfig help
-
+
+status:
+ @echo LOCAL=$(LOCAL)
+ @echo BR2_DL_DIR=$(BR2_DL_DIR)
+ @echo HOST_GLIB=$(HOST_GLIB)