summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in11
-rw-r--r--Makefile14
2 files changed, 23 insertions, 2 deletions
diff --git a/Config.in b/Config.in
index 60aefc92c..129171bbf 100644
--- a/Config.in
+++ b/Config.in
@@ -78,6 +78,17 @@ config BR2_DL_DIR
The default is $(BASE_DIR)/dl
+config BR2_HOST_GLIB
+ string "Location of host Gnome library"
+ default "/usr"
+ help
+ Directory where Gnome is installed on the host
+ Gnome applications is installed in $(BR2_HOST_LIB)/bin
+ This is needed to build libgtk etc.
+ The default is /usr
+ It can be overridden by the BUILDROOT_HOST_GLIB
+ shell variable
+
source "target/device/Config.in.mirrors"
config BR2_STAGING_DIR
diff --git a/Makefile b/Makefile
index f57d1f396..8255771ca 100644
--- a/Makefile
+++ b/Makefile
@@ -36,7 +36,7 @@ noconfig_targets:=menuconfig config oldconfig randconfig \
ifneq ($(BUILDROOT_LOCAL),)
BR2_LOCAL:=$(BUILDROOT_LOCAL)
else
-BR2_LOCAL:=$(TOPDIR)/local
+BR2_LOCAL:=$(TOPDIR)local
endif
# $(shell find . -name *_defconfig |sed 's/.*\///')
@@ -57,6 +57,12 @@ BR2_DL_DIR:=$(BUILDROOT_DL_DIR)
endif
LOCAL:=$(BR2_LOCAL)
+ifneq ($(BUILDROOT_HOST_GLIB),)
+HOST_GLIB:=$(BUILDROOT_HOST_GLIB)
+else
+HOST_GLIB:=$(BR2_HOST_GLIB)
+endif
+
# To put more focus on warnings, be less verbose as default
# Use 'make V=1' to see the full commands
ifdef V
@@ -511,4 +517,8 @@ help:
.PHONY: dummy subdirs release distclean clean config oldconfig \
menuconfig tags check test depend defconfig help
-
+
+status:
+ @echo LOCAL=$(LOCAL)
+ @echo BR2_DL_DIR=$(BR2_DL_DIR)
+ @echo HOST_GLIB=$(HOST_GLIB)