summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-08-21 13:25:30 +0200
committerBernhard Reutner-Fischer2007-08-21 13:25:30 +0200
commit7b403ada3715d1d6e510abbb6b4ccf89b2c09167 (patch)
tree381fb3e4cecf45363110f9510986c9c919d63d0e /Makefile
parent- fix incorrect invocation of non-existing binary named "-find" (diff)
downloadbuildroot-7b403ada3715d1d6e510abbb6b4ccf89b2c09167.tar.gz
buildroot-7b403ada3715d1d6e510abbb6b4ccf89b2c09167.tar.xz
buildroot-7b403ada3715d1d6e510abbb6b4ccf89b2c09167.zip
- sed -i -e "/\-[[:space:]]*mkdir[[:space:]][[:space:]]*-p/s/-[[:space:]]*mkdir/mkdir/g"
(want to know about errors if mkdir failed). Thanks to Cristian Ionescu-Idbohrn for pointing this out
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 9b1b56bb8..9a52b0b8d 100644
--- a/Makefile
+++ b/Makefile
@@ -321,7 +321,7 @@ $(CONFIG)/mconf:
fi
menuconfig: $(CONFIG)/mconf
- @-mkdir -p $(CONFIG)/buildroot-config
+ @mkdir -p $(CONFIG)/buildroot-config
@if ! KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/mconf $(CONFIG_CONFIG_IN); then \
@@ -329,39 +329,39 @@ menuconfig: $(CONFIG)/mconf
fi
config: $(CONFIG)/conf
- @-mkdir -p $(CONFIG)/buildroot-config
+ @mkdir -p $(CONFIG)/buildroot-config
@KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf $(CONFIG_CONFIG_IN)
oldconfig: $(CONFIG)/conf
- @-mkdir -p $(CONFIG)/buildroot-config
+ @mkdir -p $(CONFIG)/buildroot-config
@KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
randconfig: $(CONFIG)/conf
- @-mkdir -p $(CONFIG)/buildroot-config
+ @mkdir -p $(CONFIG)/buildroot-config
@KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf -r $(CONFIG_CONFIG_IN)
allyesconfig: $(CONFIG)/conf
cat $(CONFIG_DEFCONFIG) > .config
- @-mkdir -p $(CONFIG)/buildroot-config
+ @mkdir -p $(CONFIG)/buildroot-config
@KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
#sed -i -e "s/^CONFIG_DEBUG.*/# CONFIG_DEBUG is not set/" .config
allnoconfig: $(CONFIG)/conf
- @-mkdir -p $(CONFIG)/buildroot-config
+ @mkdir -p $(CONFIG)/buildroot-config
@KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf -n $(CONFIG_CONFIG_IN)
defconfig: $(CONFIG)/conf
- @-mkdir -p $(CONFIG)/buildroot-config
+ @mkdir -p $(CONFIG)/buildroot-config
@KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)