summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-08-21 12:56:38 +0200
committerBernhard Reutner-Fischer2007-08-21 12:56:38 +0200
commitf0ca4b8205242e3b6c2a302f0d254bb2085f76e2 (patch)
tree3f4e96410782a70b09bc28130cf8ce56f05522b4 /Makefile
parent- fix whitespace damage.. (diff)
downloadbuildroot-f0ca4b8205242e3b6c2a302f0d254bb2085f76e2.tar.gz
buildroot-f0ca4b8205242e3b6c2a302f0d254bb2085f76e2.tar.xz
buildroot-f0ca4b8205242e3b6c2a302f0d254bb2085f76e2.zip
- fix incorrect invocation of non-existing binary named "-find"
This bloated the target needlessly (and used to work before)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 5402016db..9b1b56bb8 100644
--- a/Makefile
+++ b/Makefile
@@ -250,14 +250,14 @@ endif
$(PROJECT_BUILD_DIR)/.root:
mkdir -p $(TARGET_DIR)
- if ! [ -d "$(TARGET_DIR)/bin" ] ; then \
- if [ -d "$(TARGET_SKELETON)" ] ; then \
- cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/; \
+ if ! [ -d "$(TARGET_DIR)/bin" ]; then \
+ if [ -d "$(TARGET_SKELETON)" ]; then \
+ cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/ ; \
fi; \
touch $(STAGING_DIR)/.fakeroot.00000 ; \
- -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf ; \
- -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf ; \
- fi;
+ fi
+ -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
+ -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
touch $@
$(TARGET_DIR): $(PROJECT_BUILD_DIR)/.root