summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni2010-08-21 17:21:40 +0200
committerThomas Petazzoni2010-09-01 12:26:56 +0200
commit8b6585a9d3adf35179c988a10edd16ffc2c15346 (patch)
tree4f3e824fb1d7600b88bab15dfd690970f95a0686 /Makefile
parentBump package/config to 2.6.36-rc1 (diff)
downloadbuildroot-8b6585a9d3adf35179c988a10edd16ffc2c15346.tar.gz
buildroot-8b6585a9d3adf35179c988a10edd16ffc2c15346.tar.xz
buildroot-8b6585a9d3adf35179c988a10edd16ffc2c15346.zip
Add support for the new nconf configuration tool
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 73d9335c2..fd4697213 100644
--- a/Makefile
+++ b/Makefile
@@ -28,7 +28,7 @@ CONFIG_CONFIG_IN=Config.in
CONFIG=package/config
DATE:=$(shell date +%Y%m%d)
-noconfig_targets:=menuconfig gconfig xconfig config oldconfig randconfig \
+noconfig_targets:=menuconfig nconfig gconfig xconfig config oldconfig randconfig \
defconfig %_defconfig allyesconfig allnoconfig release \
randpackageconfig allyespackageconfig allnopackageconfig \
source-check help
@@ -490,6 +490,14 @@ menuconfig: $(BUILD_DIR)/buildroot-config/mconf
test -f $(CONFIG_DIR)/.config.cmd || rm -f $(CONFIG_DIR)/.config; \
fi
+nconfig: $(BUILD_DIR)/buildroot-config/nconf
+ @mkdir -p $(BUILD_DIR)/buildroot-config
+ @if ! KCONFIG_AUTOCONFIG=$(BUILD_DIR)/buildroot-config/auto.conf \
+ KCONFIG_AUTOHEADER=$(BUILD_DIR)/buildroot-config/autoconf.h \
+ BUILDROOT_CONFIG=$(CONFIG_DIR)/.config $< $(CONFIG_CONFIG_IN); then \
+ test -f $(CONFIG_DIR)/.config.cmd || rm -f $(CONFIG_DIR)/.config; \
+ fi
+
config: $(BUILD_DIR)/buildroot-config/conf
@mkdir -p $(BUILD_DIR)/buildroot-config
@KCONFIG_AUTOCONFIG=$(BUILD_DIR)/buildroot-config/auto.conf \