summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile10
-rw-r--r--target/device/Config.in15
-rw-r--r--target/device/x86/Config.in16
-rw-r--r--target/device/x86/Makefile.in2
4 files changed, 18 insertions, 25 deletions
diff --git a/Makefile b/Makefile
index fb1716638..7a0253b5b 100644
--- a/Makefile
+++ b/Makefile
@@ -88,14 +88,8 @@ dirs: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR)
# dependencies anywhere else
#
#############################################################
-$(DL_DIR):
- @mkdir -p $(DL_DIR)
-
-$(BUILD_DIR):
- @mkdir -p $(BUILD_DIR)
-
-$(TOOL_BUILD_DIR):
- @mkdir -p $(TOOL_BUILD_DIR)
+$(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR):
+ @mkdir -p $@
$(STAGING_DIR):
@mkdir -p $(STAGING_DIR)/lib
diff --git a/target/device/Config.in b/target/device/Config.in
index d4d58ba1e..788822f0c 100644
--- a/target/device/Config.in
+++ b/target/device/Config.in
@@ -1,5 +1,20 @@
menu "Board Support Options"
+config BR2_TARGET_GENERIC
+ bool "linux kernel"
+ default n
+ select BR2_PACKAGE_LINUX
+ help
+ Architecture or board dependant linux kernel.
+
+config BR2_PACKAGE_LINUX
+ bool "linux"
+ default n
+ depends BR2_TARGET_GENERIC
+ help
+ The Linux kernel.
+ http://www.kernel.org/
+
source "target/device/AMD/Config.in"
source "target/device/Atmel/Config.in"
source "target/device/Hitachi/Config.in"
diff --git a/target/device/x86/Config.in b/target/device/x86/Config.in
index 99887b622..630795347 100644
--- a/target/device/x86/Config.in
+++ b/target/device/x86/Config.in
@@ -1,22 +1,6 @@
comment "Generic x86 Device Support"
depends BR2_i386
-config BR2_TARGET_X86_GENERIC
- bool "Generic x86 support"
- depends BR2_i386
- default n
- select BR2_PACKAGE_LINUX
- help
- Generic x86 support.
-
comment "Package support"
depends BR2_TARGET_AMD_ALCHEMY
-config BR2_PACKAGE_LINUX
- bool "linux"
- default n
- depends BR2_TARGET_X86_GENERIC
- help
- The Linux kernel.
- http://www.kernel.org/
-
diff --git a/target/device/x86/Makefile.in b/target/device/x86/Makefile.in
index 92a1cf6f3..b64e73205 100644
--- a/target/device/x86/Makefile.in
+++ b/target/device/x86/Makefile.in
@@ -1,3 +1,3 @@
-ifeq ($(strip $(BR2_TARGET_X86_GENERIC)),y)
+ifeq ($(strip $(BR2_TARGET_GENERIC)),y)
include target/device/x86/i386/Makefile.in
endif