summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-06-25 12:56:13 +0200
committerBernhard Reutner-Fischer2007-06-25 12:56:13 +0200
commitba2e7e02d16f12a9957ba10b06322102ac90427f (patch)
treefcfddbcba118513f12b291890978d851982298e4 /Makefile
parent- remove erroneously copied patch (diff)
downloadbuildroot-ba2e7e02d16f12a9957ba10b06322102ac90427f.tar.gz
buildroot-ba2e7e02d16f12a9957ba10b06322102ac90427f.tar.xz
buildroot-ba2e7e02d16f12a9957ba10b06322102ac90427f.zip
- Search for defconfigs in target, not entire tree
This patch changes the way the top level Makefile searches for a <board>_defconfig file, it will only look in the target/ directory and its sub directories. The patch also enables loading a defconfig even if there already is a .config. (Hans-Christian Egtvedt)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index cadbd847f..ceaae90fb 100644
--- a/Makefile
+++ b/Makefile
@@ -245,10 +245,6 @@ allnoconfig: $(CONFIG)/conf
defconfig: $(CONFIG)/conf
@$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
-%_defconfig: $(CONFIG)/conf
- cp $(shell find . -name $@) .config
- @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
-
# check if download URLs are outdated
source-check: allyesconfig
$(MAKE) _source-check
@@ -267,6 +263,11 @@ distclean: clean
endif # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
+%_defconfig: $(CONFIG)/conf
+ cp $(shell find ./target/ -name $@) .config
+ @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+
+
.PHONY: dummy subdirs release distclean clean config oldconfig \
menuconfig tags check test depend defconfig