summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index cadbd847f..ceaae90fb 100644
--- a/Makefile
+++ b/Makefile
@@ -245,10 +245,6 @@ allnoconfig: $(CONFIG)/conf
defconfig: $(CONFIG)/conf
@$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
-%_defconfig: $(CONFIG)/conf
- cp $(shell find . -name $@) .config
- @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
-
# check if download URLs are outdated
source-check: allyesconfig
$(MAKE) _source-check
@@ -267,6 +263,11 @@ distclean: clean
endif # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
+%_defconfig: $(CONFIG)/conf
+ cp $(shell find ./target/ -name $@) .config
+ @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+
+
.PHONY: dummy subdirs release distclean clean config oldconfig \
menuconfig tags check test depend defconfig