summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorYann E. MORIN2010-10-31 17:35:10 +0100
committerPeter Korsgaard2010-11-03 23:26:45 +0100
commite5e8fae892036360f399ed034463716f31bfd59f (patch)
tree42e0fb498800bd8f793c3025ed28b9c4ee6ff7cd /Makefile
parentMakefile: move .NOTPARALLEL (diff)
downloadbuildroot-e5e8fae892036360f399ed034463716f31bfd59f.tar.gz
buildroot-e5e8fae892036360f399ed034463716f31bfd59f.tar.xz
buildroot-e5e8fae892036360f399ed034463716f31bfd59f.zip
Makefile: move version string from Config.in into Makefile
This re-instates writing the version string in .config headers, and no longer provides it as a kconfig symbol in .config (it is now a variable in the Makefile, and in the environment). Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 3780fe6e2..8d53778b3 100644
--- a/Makefile
+++ b/Makefile
@@ -23,6 +23,9 @@
# You shouldn't need to mess with anything beyond this point...
#--------------------------------------------------------------
+# Set and export the version string
+export BR2_VERSION:=2010.11-git
+
# This top-level Makefile can *not* be executed in parallel
.NOTPARALLEL:
@@ -631,9 +634,8 @@ help:
@echo 'See docs/README and docs/buildroot.html for further details'
@echo
-release:
- OUT=buildroot-$$(grep -A2 BR2_VERSION $(CONFIG_CONFIG_IN)|grep default|cut -f2 -d\"); \
- git archive --format=tar --prefix=$$OUT/ master|gzip -9 >$$OUT.tar.gz
+release: OUT=buildroot-$(BR2_VERSION)
+ git archive --format=tar --prefix=$(OUT)/ master|gzip -9 >$(OUT).tar.gz
.PHONY: $(noconfig_targets)