summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 3780fe6e2..8d53778b3 100644
--- a/Makefile
+++ b/Makefile
@@ -23,6 +23,9 @@
# You shouldn't need to mess with anything beyond this point...
#--------------------------------------------------------------
+# Set and export the version string
+export BR2_VERSION:=2010.11-git
+
# This top-level Makefile can *not* be executed in parallel
.NOTPARALLEL:
@@ -631,9 +634,8 @@ help:
@echo 'See docs/README and docs/buildroot.html for further details'
@echo
-release:
- OUT=buildroot-$$(grep -A2 BR2_VERSION $(CONFIG_CONFIG_IN)|grep default|cut -f2 -d\"); \
- git archive --format=tar --prefix=$$OUT/ master|gzip -9 >$$OUT.tar.gz
+release: OUT=buildroot-$(BR2_VERSION)
+ git archive --format=tar --prefix=$(OUT)/ master|gzip -9 >$(OUT).tar.gz
.PHONY: $(noconfig_targets)