summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Mack2009-07-08 22:46:58 +0200
committerPeter Korsgaard2009-07-25 23:15:18 +0200
commiteed7d8737adf9669e1bcd032409595bfe7c3b119 (patch)
treed13130451b6fd7adf6000f7683f3fac62d37a716 /Makefile
parentpackage/gnuconfig: xtensa patch (diff)
downloadbuildroot-eed7d8737adf9669e1bcd032409595bfe7c3b119.tar.gz
buildroot-eed7d8737adf9669e1bcd032409595bfe7c3b119.tar.xz
buildroot-eed7d8737adf9669e1bcd032409595bfe7c3b119.zip
Add support for custom post-build script
The config help text says it all: Specify a script to be run after the build has finished and before the BR2 starts packing the files into selected packages. This gives users the oportunity to do board-specific cleanups, add-ons and the like, so the generated files can be used directly without further processing. The script is called with the target directory name as first and only argument. Make sure the exit code of that script is 0, otherwise make will stop after calling it. Signed-off-by: Daniel Mack <daniel@caiaq.de> Cc: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index f039f13d1..0fc538b6a 100644
--- a/Makefile
+++ b/Makefile
@@ -363,6 +363,10 @@ endif
find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
$(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null
+ifneq ($(BR2_ROOTFS_POST_BUILD_SCRIPT),"")
+ $(BR2_ROOTFS_POST_BUILD_SCRIPT) $(TARGET_DIR)
+endif
+
ifeq ($(BR2_ENABLE_LOCALE_PURGE),y)
LOCALE_WHITELIST=$(PROJECT_BUILD_DIR)/locales.nopurge
LOCALE_NOPURGE=$(strip $(subst ",,$(BR2_ENABLE_LOCALE_WHITELIST)))