summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--target/Config.in15
2 files changed, 19 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index f039f13d1..0fc538b6a 100644
--- a/Makefile
+++ b/Makefile
@@ -363,6 +363,10 @@ endif
find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
$(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null
+ifneq ($(BR2_ROOTFS_POST_BUILD_SCRIPT),"")
+ $(BR2_ROOTFS_POST_BUILD_SCRIPT) $(TARGET_DIR)
+endif
+
ifeq ($(BR2_ENABLE_LOCALE_PURGE),y)
LOCALE_WHITELIST=$(PROJECT_BUILD_DIR)/locales.nopurge
LOCALE_NOPURGE=$(strip $(subst ",,$(BR2_ENABLE_LOCALE_WHITELIST)))
diff --git a/target/Config.in b/target/Config.in
index a25581baa..ab46dcb16 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -12,6 +12,21 @@ config BR2_ROOTFS_SUFFIX
help
Add a custom string to the end of the root file system name.
+config BR2_ROOTFS_POST_BUILD_SCRIPT
+ string "Custom script to run before packing files"
+ default ""
+ help
+ Specify a script to be run after the build has finished and before
+ the BR2 starts packing the files into selected packages.
+
+ This gives users the oportunity to do board-specific cleanups,
+ add-ons and the like, so the generated files can be used directly
+ without further processing.
+
+ The script is called with the target directory name as first and
+ only argument. Make sure the exit code of that script is 0,
+ otherwise make will stop after calling it.
+
comment "filesystem for target device"
source "target/cramfs/Config.in"