summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2009-01-25 21:19:01 +0100
committerPeter Korsgaard2009-01-25 21:19:01 +0100
commitf85f2de174779aaf02cf2a858b2ba28c4cb6f843 (patch)
treecccb73c590bd563268b57468370bdfa36991fa97 /Makefile
parentkernel-headers: bump 2.6.27 / 2.6.28 to latest stable (diff)
downloadbuildroot-f85f2de174779aaf02cf2a858b2ba28c4cb6f843.tar.gz
buildroot-f85f2de174779aaf02cf2a858b2ba28c4cb6f843.tar.xz
buildroot-f85f2de174779aaf02cf2a858b2ba28c4cb6f843.zip
Makefile: globally define variables used at different places
$(comma) and $(space) are used in packages and the toolchain. Signed-off-by: Markus Heidelberg <markus.heidelberg@web.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 6b12c76c5..a55d9bbb9 100644
--- a/Makefile
+++ b/Makefile
@@ -40,6 +40,11 @@ else
BR2_LOCAL:=$(TOPDIR)/local
endif
+# Variables for use in Make constructs
+comma:=,
+empty:=
+space:=$(empty) $(empty)
+
# $(shell find . -name *_defconfig |sed 's/.*\///')
# Pull in the user's configuration file
ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)