summaryrefslogtreecommitdiffstats
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorThomas Petazzoni2010-04-28 23:40:45 +0200
committerPeter Korsgaard2010-05-02 23:26:22 +0200
commitd2c73f5cf925baf1bcf99c1a187e2a846dd56f43 (patch)
tree183afe8e5234e2e29af3025d851c2ec1f0e391d8 /package/Makefile.autotools.in
parentopenssl: convert to the generic infrastructure (diff)
downloadbuildroot-d2c73f5cf925baf1bcf99c1a187e2a846dd56f43.tar.gz
buildroot-d2c73f5cf925baf1bcf99c1a187e2a846dd56f43.tar.xz
buildroot-d2c73f5cf925baf1bcf99c1a187e2a846dd56f43.zip
autotools: inherit LIBTOOL_PATCH for host packages
When FOO_LIBTOOL_PATCH is defined, assume that the same value should be used for HOST_FOO_LIBTOOL_PATCH. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index fc5bcee34..bbc79b7c8 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -49,6 +49,14 @@ ifndef $(2)_SUBDIR
endif
endif
+ifndef $(2)_LIBTOOL_PATCH
+ ifdef $(3)_LIBTOOL_PATCH
+ $(2)_LIBTOOL_PATCH = $($(3)_LIBTOOL_PATCH)
+ else
+ $(2)_LIBTOOL_PATCH ?= YES
+ endif
+endif
+
$(2)_CONF_ENV ?=
$(2)_CONF_OPT ?=
$(2)_MAKE ?= $(MAKE)
@@ -56,7 +64,6 @@ $(2)_MAKE_ENV ?=
$(2)_MAKE_OPT ?=
$(2)_AUTORECONF ?= NO
$(2)_AUTORECONF_OPT ?=
-$(2)_LIBTOOL_PATCH ?= YES
$(2)_USE_CONFIG_CACHE ?= $(if $(BR2_CONFIG_CACHE),YES,NO)
$(2)_INSTALL_STAGING_OPT ?= DESTDIR=$$(STAGING_DIR) install
ifeq ($(BR2_ENABLE_DEBUG),y)