summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Makefile.autotools.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index fc5bcee34..bbc79b7c8 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -49,6 +49,14 @@ ifndef $(2)_SUBDIR
endif
endif
+ifndef $(2)_LIBTOOL_PATCH
+ ifdef $(3)_LIBTOOL_PATCH
+ $(2)_LIBTOOL_PATCH = $($(3)_LIBTOOL_PATCH)
+ else
+ $(2)_LIBTOOL_PATCH ?= YES
+ endif
+endif
+
$(2)_CONF_ENV ?=
$(2)_CONF_OPT ?=
$(2)_MAKE ?= $(MAKE)
@@ -56,7 +64,6 @@ $(2)_MAKE_ENV ?=
$(2)_MAKE_OPT ?=
$(2)_AUTORECONF ?= NO
$(2)_AUTORECONF_OPT ?=
-$(2)_LIBTOOL_PATCH ?= YES
$(2)_USE_CONFIG_CACHE ?= $(if $(BR2_CONFIG_CACHE),YES,NO)
$(2)_INSTALL_STAGING_OPT ?= DESTDIR=$$(STAGING_DIR) install
ifeq ($(BR2_ENABLE_DEBUG),y)