summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorMike Frysinger2005-09-18 06:41:57 +0200
committerMike Frysinger2005-09-18 06:41:57 +0200
commite4de8b2f1414965ca2989eb3a90094ae5ff2224f (patch)
tree88b192b4990ee1144f8bdd4a609d28d29182057e /package/Makefile.in
parentAdd patches for latest snapshot of gdb. The starting point was the 6.3 (diff)
downloadbuildroot-e4de8b2f1414965ca2989eb3a90094ae5ff2224f.tar.gz
buildroot-e4de8b2f1414965ca2989eb3a90094ae5ff2224f.tar.xz
buildroot-e4de8b2f1414965ca2989eb3a90094ae5ff2224f.zip
add sf mirrors list in help (fix by Bernhard Fischer) and allow people to add custom prefix/suffix to builds
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index a81d469a1..297ecffd5 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -16,13 +16,23 @@ DISABLE_LARGEFILE= --disable-largefile
endif
TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING)
+TOPDIR_PREFIX:=$(strip $(subst ",, $(BR2_TOPDIR_PREFIX)))_
+TOPDIR_SUFFIX:=_$(strip $(subst ",, $(BR2_TOPDIR_SUFFIX)))
+ifeq ($(TOPDIR_PREFIX),_)
+TOPDIR_PREFIX:=
+endif
+ifeq ($(TOPDIR_SUFFIX),_)
+TOPDIR_SUFFIX:=
+endif
+
HOSTCC:=gcc
BASE_DIR:=${shell pwd}
DL_DIR:=$(BASE_DIR)/dl
#PATCH_DIR=$(BASE_DIR)/sources/patches
-BUILD_DIR:=$(BASE_DIR)/build_$(ARCH)$(ARCH_FPU_SUFFIX)
+BUILD_DIR:=$(BASE_DIR)/$(TOPDIR_PREFIX)build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_SUFFIX)
TARGET_DIR:=$(BUILD_DIR)/root
-TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build_$(ARCH)$(ARCH_FPU_SUFFIX)
+TOOL_BUILD_DIR=$(BASE_DIR)/$(TOPDIR_PREFIX)toolchain_build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_SUFFIX)
+
# Strip off the annoying quoting
STAGING_DIR:=$(strip $(subst ",, $(BR2_STAGING_DIR)))
#"