summaryrefslogtreecommitdiffstats
path: root/package/python-id3/python-id3.mk
diff options
context:
space:
mode:
authorPeter Korsgaard2012-05-31 09:23:23 +0200
committerPeter Korsgaard2012-05-31 09:23:23 +0200
commitbdb4c3a6dc9efecc4d1e40fabf8cb9b3e0eb3ee2 (patch)
treed6012109e704c5e9abc709c23a7133a3d4b4f779 /package/python-id3/python-id3.mk
parentKickoff 2012.08 cycle (diff)
parentnfs-utils: bump to version 1.2.6 (diff)
downloadbuildroot-bdb4c3a6dc9efecc4d1e40fabf8cb9b3e0eb3ee2.tar.gz
buildroot-bdb4c3a6dc9efecc4d1e40fabf8cb9b3e0eb3ee2.tar.xz
buildroot-bdb4c3a6dc9efecc4d1e40fabf8cb9b3e0eb3ee2.zip
Merge branch 'next'
Conflicts: toolchain/kernel-headers/Config.in
Diffstat (limited to 'package/python-id3/python-id3.mk')
-rw-r--r--package/python-id3/python-id3.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/python-id3/python-id3.mk b/package/python-id3/python-id3.mk
new file mode 100644
index 000000000..e1ed1b606
--- /dev/null
+++ b/package/python-id3/python-id3.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# python-id3
+#
+#############################################################
+
+PYTHON_ID3_VERSION = 1.2
+PYTHON_ID3_SOURCE = id3-py_$(PYTHON_ID3_VERSION).tar.gz
+PYTHON_ID3_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/id3-py
+
+PYTHON_ID3_DEPENDENCIES = python
+
+define PYTHON_ID3_BUILD_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_ID3_INSTALL_TARGET_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+$(eval $(call GENTARGETS))