summaryrefslogtreecommitdiffstats
path: root/package/python-id3/python-id3.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/python-id3/python-id3.mk')
-rw-r--r--package/python-id3/python-id3.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/python-id3/python-id3.mk b/package/python-id3/python-id3.mk
new file mode 100644
index 000000000..e1ed1b606
--- /dev/null
+++ b/package/python-id3/python-id3.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# python-id3
+#
+#############################################################
+
+PYTHON_ID3_VERSION = 1.2
+PYTHON_ID3_SOURCE = id3-py_$(PYTHON_ID3_VERSION).tar.gz
+PYTHON_ID3_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/id3-py
+
+PYTHON_ID3_DEPENDENCIES = python
+
+define PYTHON_ID3_BUILD_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_ID3_INSTALL_TARGET_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+$(eval $(call GENTARGETS))