summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--docs/manual/rebuilding-packages.txt4
2 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 30099d99d..3a09417ad 100644
--- a/Makefile
+++ b/Makefile
@@ -654,6 +654,8 @@ help:
@echo
@echo 'Build:'
@echo ' all - make world'
+ @echo ' <package>-rebuild - force recompile <package>'
+ @echo ' <package>-reconfigure - force reconfigure <package>'
@echo
@echo 'Configuration:'
@echo ' menuconfig - interactive curses-based configurator'
diff --git a/docs/manual/rebuilding-packages.txt b/docs/manual/rebuilding-packages.txt
index 9a41a88ac..f247dd04f 100644
--- a/docs/manual/rebuilding-packages.txt
+++ b/docs/manual/rebuilding-packages.txt
@@ -15,6 +15,10 @@ The easiest way to rebuild a single package from scratch is to remove
its build directory in +output/build+. Buildroot will then re-extract,
re-configure, re-compile and re-install this package from scratch.
+For convenience, most packages support the special make targets
+<package>-reconfigure and <package>-rebuild to repeat the configure
+and build steps.
+
However, if you don't want to rebuild the package completely from
scratch, a better understanding of the Buildroot internals is
needed. Internally, to keep track of which steps have been done and