summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES1
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk7
2 files changed, 8 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index aed229818..c0a6485fb 100644
--- a/CHANGES
+++ b/CHANGES
@@ -8,6 +8,7 @@
#753: Bump lighttpd package to 1.4.25
#761: Add binutils 2.20 to toolchain options
#763: [SECURITY] Update pcre to 7.9
+ #765: Add buildroot branding to gcc
2009.11, Released December 1st, 2009:
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 241bfb3bf..d5a889fa3 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -65,6 +65,13 @@ ifeq ($(findstring x4.0.,x$(GCC_VERSION)),x4.0.)
GCC_NO_MPFR:=y
endif
+# Branding works on >= 4.3
+ifneq ($(findstring x4.2.,x$(GCC_VERSION)),x4.2)
+BUILDROOT_VERSION_STRING=$(call qstrip,$(BR2_VERSION))
+EXTRA_GCC_CONFIG_OPTIONS+=--with-pkgversion="Buildroot $(BUILDROOT_VERSION_STRING)" \
+ --with-bugurl="http://bugs.buildroot.net/"
+endif
+
GCC_TARGET_PREREQ=
GCC_STAGING_PREREQ=