summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES3
-rw-r--r--package/Config.in1
-rw-r--r--package/hostap/Config.in9
-rw-r--r--package/hostap/hostap.mk72
4 files changed, 2 insertions, 83 deletions
diff --git a/CHANGES b/CHANGES
index 4709fdfe5..3a1d1f65b 100644
--- a/CHANGES
+++ b/CHANGES
@@ -5,11 +5,12 @@
Updated/fixed packages: busybox, ipsec-tools, libgtk2, madplay,
netsnmp, pango, sylpheed, qt, xfont_font-util
- Removed packages: openmotif, xpdf
+ Removed packages: hostap, openmotif, xpdf
Issues resolved (http://bugs.uclibc.org):
#165: openmotif does not build
+ #1147: Remove obsolete hostap package
#1183: make source fails to download gmp, mpfr and patches
2010.02-rc2, Released February 23th, 2010:
diff --git a/package/Config.in b/package/Config.in
index b21604d5c..5dc7c8d5e 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -138,7 +138,6 @@ source "package/dnsmasq/Config.in"
source "package/dropbear/Config.in"
source "package/ethtool/Config.in"
source "package/haserl/Config.in"
-source "package/hostap/Config.in"
source "package/hostapd/Config.in"
source "package/ifplugd/Config.in"
source "package/iperf/Config.in"
diff --git a/package/hostap/Config.in b/package/hostap/Config.in
deleted file mode 100644
index 74431b787..000000000
--- a/package/hostap/Config.in
+++ /dev/null
@@ -1,9 +0,0 @@
-config BR2_PACKAGE_HOSTAP
- bool "hostap"
- depends on BR2_DEPRECATED
- select BR2_PACKAGE_PCMCIA
- help
- Linux driver for wireless LAN cards based on Intersil's
- Prism2/2.5/3 chipset.
-
- http://hostap.epitest.fi/
diff --git a/package/hostap/hostap.mk b/package/hostap/hostap.mk
deleted file mode 100644
index d0af5fd1d..000000000
--- a/package/hostap/hostap.mk
+++ /dev/null
@@ -1,72 +0,0 @@
-#############################################################
-#
-# hostap
-#
-# Note! Host AP driver was added into the main kernel tree in Linux v2.6.14.
-# The version in the kernel tree should be used instead of this external
-# hostap-driver package.
-# The external releases are only for older kernel versions and all
-# the future development will be in the main kernel tree.
-#
-#############################################################
-HOSTAP_VERSION=0.4.9
-HOSTAP_SOURCE=hostap-driver-$(HOSTAP_VERSION).tar.gz
-HOSTAP_SITE=http://hostap.epitest.fi/releases
-HOSTAP_DIR=$(BUILD_DIR)/hostapd-$(HOSTAP_VERSION)
-
-$(DL_DIR)/$(HOSTAP_SOURCE):
- $(call DOWNLOAD,$(HOSTAP_SITE),$(HOSTAP_SOURCE))
-
-hostap-source: $(DL_DIR)/$(HOSTAP_SOURCE)
-
-$(HOSTAP_DIR)/.unpacked: $(DL_DIR)/$(HOSTAP_SOURCE)
- $(ZCAT) $(DL_DIR)/$(HOSTAP_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- mv -f $(BUILD_DIR)/hostap $(HOSTAP_DIR)
- touch $@
-
-$(HOSTAP_DIR)/.configured: $(HOSTAP_DIR)/.unpacked
- #$(SED) "s,/.*#define PRISM2_DOWNLOAD_SUPPORT.*/,#define PRISM2_DOWNLOAD_SUPPORT,g" \
- # $(HOSTAP_DIR)/driver/modules/hostap_config.h
- touch $@
-
-$(HOSTAP_DIR)/utils/hostap_crypt_conf: $(HOSTAP_DIR)/.configured
- $(MAKE) -C $(HOSTAP_DIR)/utils \
- CC=$(TARGET_CC) \
- CFLAGS="-Os -Wall $(TARGET_CFLAGS) -I../driver/modules"
- $(MAKE) -C $(HOSTAP_DIR)/hostapd \
- CC=$(TARGET_CC) \
- CFLAGS="-Os -Wall $(TARGET_CFLAGS) -I../driver/modules -I../utils"
- touch -c $(HOSTAP_DIR)/driver/modules/hostap.o
-
-$(TARGET_DIR)//usr/bin/hostap_crypt_conf: $(HOSTAP_DIR)/utils/hostap_crypt_conf
- # Make the dir
- rm -rf $(HOSTAP_TARGET_MODULE_DIR)
- mkdir -p $(HOSTAP_TARGET_MODULE_DIR)
- # Copy the pcmcia-cs conf file
- mkdir -p $(TARGET_DIR)/etc/pcmcia
- cp -af $(HOSTAP_DIR)/driver/etc/hostap_cs.conf $(TARGET_DIR)/etc/pcmcia/
- # Copy The Utils
- cp -af $(HOSTAP_DIR)/utils/hostap_crypt_conf $(TARGET_DIR)/usr/bin/
- cp -af $(HOSTAP_DIR)/utils/hostap_diag $(TARGET_DIR)/usr/bin/
- cp -af $(HOSTAP_DIR)/utils/prism2_param $(TARGET_DIR)/usr/bin/
- cp -af $(HOSTAP_DIR)/utils/prism2_srec $(TARGET_DIR)/usr/bin/
- # Copy hostapd
- cp -af $(HOSTAP_DIR)/hostapd/hostapd $(TARGET_DIR)/usr/sbin/
-
-hostap: pcmcia $(TARGET_DIR)//usr/bin/hostap_crypt_conf
-
-hostap-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(HOSTAP_DIR) uninstall
- -$(MAKE) -C $(HOSTAP_DIR) clean
-
-hostap-dirclean:
- rm -rf $(HOSTAP_DIR)
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_PACKAGE_HOSTAP),y)
-TARGETS+=hostap
-endif