summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile8
-rw-r--r--package/Makefile.autotools.in1
2 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index df276c11b..d6bcb36f0 100644
--- a/Makefile
+++ b/Makefile
@@ -441,12 +441,12 @@ show-targets:
@echo $(TARGETS)
ifeq ($(BR2_CONFIG_CACHE),y)
-# drop configure cache if configuration is changed
-$(BUILD_DIR)/tgt-config.cache: $(CONFIG_DIR)/.config
+# drop configure caches if configuration is changed
+$(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache: $(CONFIG_DIR)/.config
rm -f $@
touch $@
-$(BASE_TARGETS): | $(BUILD_DIR)/tgt-config.cache
+$(BASE_TARGETS): | $(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache
endif
else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
@@ -580,7 +580,7 @@ endif
rm -rf $(CONFIG_DIR)/.config $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/.config.cmd $(CONFIG_DIR)/.auto.deps
flush:
- rm -f $(BUILD_DIR)/tgt-config.cache
+ rm -f $(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache
%_defconfig: $(TOPDIR)/configs/%_defconfig
cp $^ $(CONFIG_DIR)/.config
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 318bd714a..337aee488 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -117,6 +117,7 @@ define $(2)_CONFIGURE_CMDS
LDFLAGS="$$(HOST_LDFLAGS)" \
$$($$(PKG)_CONF_ENV) \
./configure \
+ $$(if $$(filter YES,$$($$(PKG)_USE_CONFIG_CACHE)),--cache-file="$(BUILD_DIR)/host-config.cache",) \
--prefix="$$(HOST_DIR)/usr" \
--sysconfdir="$$(HOST_DIR)/etc" \
$$($$(PKG)_CONF_OPT) \