summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES5
-rw-r--r--package/openssl/openssl.mk6
2 files changed, 7 insertions, 4 deletions
diff --git a/CHANGES b/CHANGES
index f26f67f17..259fd0471 100644
--- a/CHANGES
+++ b/CHANGES
@@ -7,8 +7,8 @@
New packages: cgilua, copas, coxpcall, luafilesystem,
luasocket, rings, wsapi, xavante
- Updated/fixed packages: cdrkit, libidn, netperf, php, qt,
- tn5250, usbutils
+ Updated/fixed packages: cdrkit, libidn, netperf, openssl, php,
+ qt, tn5250, usbutils
Removed packages: modutils
@@ -21,6 +21,7 @@
#1903: Bump tn5250 to 0.17.4 and migrate to autotargets
#1909: netperf-2.4.5 fails to build because of undeclared SOCK_DCCP
#1945: PHP: add sqlite3 dependency when using external lib
+ #1951: Bump openssl to 0.9.8o
2010.05, Released May 30th, 2010:
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index c52e256ac..330b6042b 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -3,7 +3,7 @@
# openssl
#
#############################################################
-OPENSSL_VERSION:=0.9.8n
+OPENSSL_VERSION:=0.9.8o
OPENSSL_SITE:=http://www.openssl.org/source
OPENSSL_INSTALL_STAGING = YES
OPENSSL_DEPENDENCIES = zlib
@@ -32,8 +32,10 @@ define OPENSSL_CONFIGURE_CMDS
threads \
shared \
no-idea \
- no-mdc2 \
no-rc5 \
+ enable-camellia \
+ enable-mdc2 \
+ enable-tlsext \
zlib-dynamic \
)
$(SED) "s:-march=[-a-z0-9] ::" -e "s:-mcpu=[-a-z0-9] ::g" $(@D)/Makefile