summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES7
-rw-r--r--package/openssl/openssl.mk5
2 files changed, 9 insertions, 3 deletions
diff --git a/CHANGES b/CHANGES
index 09088041e..c22d0b6ca 100644
--- a/CHANGES
+++ b/CHANGES
@@ -4,12 +4,13 @@
avahi, busybox, dnsmasq, dropbear, ethtool, fakeroot, ffmpeg,
file, gnuconfig, gst-ffmpeg, gst-plugins-good, icu,
imagemagick, libdnet, libpng, libxml2, libxslt, makedevs,
- mpg123, mtd-utils, ncurses, netsnmp, pkg-config, qt, samba,
- socat, squashfs, webkit, xerces, xlib_xtrans, xorg-server,
- xterm, xz
+ mpg123, mtd-utils, ncurses, netsnmp, openssl, pkg-config, qt,
+ samba, socat, squashfs, webkit, xerces, xlib_xtrans,
+ xorg-server, xterm, xz
Issues resolved (http://bugs.uclibc.org):
+ #3445: Not working openssl-10.0.0d on 386sx
#3451: fakeroot package: wrong FAKEROOT_SITE variable
#3457: alsamixergui: broken URL
#3475: Calling sync on large filesystems when not always necessary
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index 7bf347ad8..0163ef847 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -39,6 +39,11 @@ ifeq ($(ARCH),x86_64)
OPENSSL_TARGET_ARCH = x86_64
endif
+# Workaround for bug #3445
+ifeq ($(BR2_x86_i386),y)
+ OPENSSL_TARGET_ARCH = generic32 386
+endif
+
define OPENSSL_CONFIGURE_CMDS
(cd $(@D); \
$(TARGET_CONFIGURE_ARGS) \