summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES3
-rw-r--r--package/Config.in1
-rw-r--r--package/bonnie/Config.in10
-rw-r--r--package/bonnie/bonnie.mk18
4 files changed, 31 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 19d2cc518..0b1189861 100644
--- a/CHANGES
+++ b/CHANGES
@@ -9,10 +9,11 @@
quagga, readline, rsync, samba, squid, socat, squashfs, tslib,
webkit, xerces, xlib_xtrans, xorg-server, xterm, xz
- New packages: can-utils, htop, libv4l
+ New packages: bonnie++, can-utils, htop, libv4l
Issues resolved (http://bugs.uclibc.org):
+ #3379: New Package: bonnie++
#3445: Not working openssl-10.0.0d on 386sx
#3451: fakeroot package: wrong FAKEROOT_SITE variable
#3457: alsamixergui: broken URL
diff --git a/package/Config.in b/package/Config.in
index 71dc0a80a..b5a1ee4f6 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -17,6 +17,7 @@ source "package/xz/Config.in"
endmenu
menu "Debugging, profiling and benchmark"
+source "package/bonnie/Config.in"
source "package/dhrystone/Config.in"
source "package/dmalloc/Config.in"
source "package/kexec/Config.in"
diff --git a/package/bonnie/Config.in b/package/bonnie/Config.in
new file mode 100644
index 000000000..9dda4b6cd
--- /dev/null
+++ b/package/bonnie/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_BONNIE
+ bool "bonnie++"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ Filesystem tester
+
+ http://www.coker.com.au/bonnie++/
+
+comment "bonnie++ requires a toolchain with C++ support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/bonnie/bonnie.mk b/package/bonnie/bonnie.mk
new file mode 100644
index 000000000..9a6188fa4
--- /dev/null
+++ b/package/bonnie/bonnie.mk
@@ -0,0 +1,18 @@
+#
+# bonnie++
+#
+
+BONNIE_VERSION = 1.03e
+BONNIE_SOURCE = bonnie++-$(BONNIE_VERSION).tgz
+BONNIE_SITE = http://www.coker.com.au/bonnie++/
+
+define BONNIE_INSTALL_TARGET_CMDS
+ install -D -m 755 $(@D)/bonnie++ $(TARGET_DIR)/usr/sbin/bonnie++
+ install -D -m 755 $(@D)/zcav $(TARGET_DIR)/usr/sbin/zcav
+endef
+
+define BONNIE_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/usr/sbin/bonnie++ $(TARGET_DIR)/usr/sbin/zcav
+endef
+
+$(eval $(call AUTOTARGETS,package,bonnie))