summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES1
-rw-r--r--package/qt/qt.mk3
2 files changed, 2 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index 26cda06a4..4fef0eb1e 100644
--- a/CHANGES
+++ b/CHANGES
@@ -22,6 +22,7 @@
#561: ltp-testsuite failed to install
#1651: Build fail caused by ccache in module-init-tools
#1735: [PATCH] mplayer: convert to autotools infrastructure
+ #2371: QT MYSQL Module does not build when MySQL installed on the host
#2905: Qt: Speed up compilation, if gui-module isn't selected
#2965: Broken linkage to xkbcomp (blocking X server startup)
#2983: xlib_libX11 build failed
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 2b5b31b78..6eb31bccb 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -283,8 +283,7 @@ ifeq ($(BR2_PACKAGE_QT_IBASE),y)
QT_CONFIGURE+= -qt-sql-ibase
endif
ifeq ($(BR2_PACKAGE_QT_MYSQL),y)
-QT_CONFIGURE+= -qt-sql-mysql -I $(STAGING_DIR)/usr/include/mysql -L $(STAGING_DIR)/usr/lib/mysql
-
+QT_CONFIGURE+= -qt-sql-mysql -mysql_config $(STAGING_DIR)/usr/bin/mysql_config
QT_DEP_LIBS+=mysql_client
endif
ifeq ($(BR2_PACKAGE_QT_ODBC),y)