summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in6
-rw-r--r--package/Makefile.in9
2 files changed, 13 insertions, 2 deletions
diff --git a/Config.in b/Config.in
index 30da7b654..8714bc633 100644
--- a/Config.in
+++ b/Config.in
@@ -125,6 +125,12 @@ config BR2_TAR_VERBOSITY
bool "Tar verbose"
default n
+config BR2_DL_DIR
+ string "Download dir"
+ default "$(BASE_DIR)/dl"
+ help
+ Directory to store all the source files that we need to fetch.
+
config BR2_SOURCEFORGE_MIRROR
string "Sourceforge mirror site"
default "easynews"
diff --git a/package/Makefile.in b/package/Makefile.in
index 297ecffd5..662ecacef 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -11,10 +11,14 @@ SVN:=$(strip $(subst ",, $(BR2_SVN)))
+
ifneq ($(BR2_LARGEFILE),y)
DISABLE_LARGEFILE= --disable-largefile
endif
TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING)
+HOSTCC:=gcc
+
+BASE_DIR:=${shell pwd}
TOPDIR_PREFIX:=$(strip $(subst ",, $(BR2_TOPDIR_PREFIX)))_
TOPDIR_SUFFIX:=_$(strip $(subst ",, $(BR2_TOPDIR_SUFFIX)))
@@ -25,9 +29,10 @@ ifeq ($(TOPDIR_SUFFIX),_)
TOPDIR_SUFFIX:=
endif
-HOSTCC:=gcc
-BASE_DIR:=${shell pwd}
+DL_DIR=$(strip $(subst ",, $(BR2_DL_DIR)))
+ifeq ($(DL_DIR),)
DL_DIR:=$(BASE_DIR)/dl
+endif
#PATCH_DIR=$(BASE_DIR)/sources/patches
BUILD_DIR:=$(BASE_DIR)/$(TOPDIR_PREFIX)build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_SUFFIX)
TARGET_DIR:=$(BUILD_DIR)/root