summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in13
-rw-r--r--package/Makefile.in2
2 files changed, 14 insertions, 1 deletions
diff --git a/Config.in b/Config.in
index db5c84b4a..89bca3b87 100644
--- a/Config.in
+++ b/Config.in
@@ -178,6 +178,19 @@ config BR2_TOPDIR_SUFFIX
build_ARCH -> build_ARCH_[SUFFIX]
toolchain_build_ARCH -> toolchain_build_ARCH_[SUFFIX]
+config BR2_GNU_BUILD_SUFFIX
+ string "GNU build hostname suffix"
+ default "pc-linux-gnu"
+ help
+ The string used to pass to configure scripts via the
+ --build= option. Just specify the suffix here, the leading
+ arch will be filled in automatically.
+
+ Here's some copy and paste build host options for you:
+ linux: pc-linux-gnu
+ cygwin: pc-cygwin
+ os x: apple-darwin7 / apple-darwin8
+
config BR2_JLEVEL
int "Number of jobs to run simultaneously"
default "1"
diff --git a/package/Makefile.in b/package/Makefile.in
index 281680aa4..ce4fb28f5 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -65,7 +65,7 @@ HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-e 's/cris.*/cris/' \
-e 's/i[3-9]86/i386/' \
)
-GNU_HOST_NAME:=$(HOST_ARCH)-pc-linux-gnu
+GNU_HOST_NAME:=$(HOST_ARCH)-$(subst ",,$(BR2_GNU_BUILD_SUFFIX))
TARGET_CONFIGURE_OPTS=PATH=$(TARGET_PATH) \
AR=$(TARGET_CROSS)ar \
AS=$(TARGET_CROSS)as \