summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/grep/grep.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index e8b9cfef2..e039135b3 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -4,7 +4,7 @@
#
#############################################################
-GREP_VERSION = 2.7
+GREP_VERSION = 2.9
GREP_SITE = $(BR2_GNU_MIRROR)/grep
GREP_CONF_OPT = --disable-perl-regexp --without-included-regex
GREP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext libintl)
@@ -15,4 +15,9 @@ GREP_CONF_ENV += LIBS=-liconv
GREP_DEPENDENCIES += libiconv
endif
+# Full grep preferred over busybox grep
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+GREP_DEPENDENCIES += busybox
+endif
+
$(eval $(call AUTOTARGETS))