summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in10
-rw-r--r--Makefile5
2 files changed, 5 insertions, 10 deletions
diff --git a/Config.in b/Config.in
index f62f9c973..db5c84b4a 100644
--- a/Config.in
+++ b/Config.in
@@ -121,13 +121,13 @@ config BR2_SVN
string "Subversion (svn) checkout command"
default "svn co"
-config BR2_TAR_VERBOSITY
- bool "Tar verbose"
- default n
-
config BR2_TAR_OPTIONS
string "Tar options"
- default "--exclude='.svn'"
+ default ""
+ help
+ Options to pass to tar when extracting the sources.
+ E.g. " -v --exclude='*.svn*'" to exclude all .svn internal files
+ and to be verbose.
config BR2_DL_DIR
string "Download dir"
diff --git a/Makefile b/Makefile
index 629129603..1f52a15eb 100644
--- a/Makefile
+++ b/Makefile
@@ -35,13 +35,8 @@ ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
-include $(TOPDIR).config
endif
-ifeq ($(BR2_TAR_VERBOSITY),y)
-TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xvf
-#"
-else
TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
#"
-endif
ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)